Librewriter screen display text gets messed up after scrolling

In librewriter when scrolling up/down the text gets garbled and duplicated fragments of lines everywhere. Screen messed up–like it’s not erasing the old text before displaying the current text. Scrolling up/down does not clean up the screen line fragments.

On which operating system are you experiencing this issue? I know it often occurs on OS X… Please specify your OS with version number, your version of LibreOffice and wether the issue has always been present or started after a change in configuration.

Libre Officel, Ubuntu 12.10 fallback GNOME Classic (no effects), always present.

Perhaps the issue is related to Gnome’s “Fallback” mode? I reckon this mode uses older API’s and frameworks…

Installed OpenOffice. No line fragment issue.

Aha! That’s interesting, and deserves further investigation.

@ubuntu12p10 - What version of OpenOffice are you saying is not affected by this?

@ubuntu12p10 - Now I see that OpenOffice is version 3.4.1 (while LO is 4.0.1). If these numbers are at least partly correlated, there’s no wander OO 3.4 is not affected by the bug: you might as well use LO 3.5

I’ve got the same problem with LibreOffice, Ubuntu 14.04. Selecting an appropriate JRE Version at Tools->Options->LibreOffice->Advanced helped a lot!

Then it probably has something to do with LibreOffice’s text display being handled by Java? I knew Java handled user interaction, but I wasn’t sure to what extent it was responsible for display in the document view. I am aware of other applications (such as PyCharm) where changing the JRE can dramatically alter the appearance of text.

I do not have a solution per se, but some advice.

It looks like i have the same problem. This is my question. I think it is the same, look at the images and comment please.

I have filed a bug report here. You may want to add your comments there too. Try to provide info on your operating system, VGA and drivers.

It happened for me first with 3.6 in Ubuntu and then with all the other newer releases. Going back to 3.5 solved it. Updating is not a solution just yet, downgrading to 3.5 is. (That is why OpenOffice is not affected: it is based on a such older version of the program.) To test 3.5 without affecting your normal current installation, try a ‘local’ install, like indicated here. In the same manner you may test the latest versions to see if the bug is still affecting them.

Also, in my case it happens only above a certain zoom level. Try to use a lower zoom level and see if the problem goes away, and then avoid going above that.

Hi @ubuntu12p10,

If installing/running the latest release doesn’t seem to fix this problem, please file a bug and provide a list of steps that can reproduce your problem. The QA Team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


I have the same problem (see my answer above, including the bug report). there are not too many steps to reconstitute here: it is just that a display problem with certain VGA/video-drivers has appeared in 3.6 version. all previous versions are not affected. the current (june 2013 v.3.4.1) OpenOffice is not affected either.

same problem after upgrading from ubuntu 12.10 to 14.04 and libreoffice Version:

problem was solved by changing JRE setting (as indicated above by markus69, thanks!) from old sun 1.6 to oracle 1.7. seems oracle JRE was updated while updating ubuntu, not sun’s