Ask Your Question
0

"Send -> document via email" doesn't work

asked 2017-07-06 08:35:18 +0200

jampjamp gravatar image

I've asked once for it #, but no-one helped, so I'll try again.

It shows "LibreOffice was unable to find a working email configuration", I've tried to reinstall Thunderbird (which is set to be default MAPI mail sender in Windows' control panel). I've also updated LibreOffice to the newest revision. Nothing has worked. I found many solutions, but it's rather for a Linux. Any ideas what can I do more? "Mailto" in webbrowser works correct, it opens Thunderbird.

edit retag flag offensive close merge delete

Comments

My solution on an old Windows XP box turned out be this (though I use operamail instead of TB):

Keep outlook as the default emailer. Make sure it's set up properly.

Note that during your testing of the Outlook Express configuration it may well give you authentication certificate errors. Accept the connection if you get such dialogs. Since I am presuming that Thunderbird uses TSL instead of SSL, this won't be a problem since most of the time you plan to use TB for the inbound stuff. TSL doesn't seem to suffer from the certificate issue the way SSL does.

In Outlook Express options disable the parts where it automatically checks for new messages upon launch, or at timed intervals.

Now you can still use TB as normal, but if you use the send options in LiibreOffice it will find and use Outlook Express to making attachments ...(plus)

Credo gravatar imageCredo ( 2020-04-22 23:13:25 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-07-06 09:51:10 +0200

updated 2018-03-09 17:43:04 +0200

  1. For Windows, there's no EMail setup options in Internet top-level configuration category. Sending is done using LibreOffice's senddoc.exe program, that in turn simply uses Windows MAPI dll (mapi32.dll; see senddoc.cxx:259 and simplemapi.cxx:30). The Windows dll's MAPISendMail function does all actual job. So, the failure to find the mailer happens outside LibreOffice's code. I only could guess that LO/TB bitness might have something to do with this problem.

  2. It's unhelpful to double-post. If you really need to send your question again, then at least remove your previous one, to keep things clean. Or, better, just update your initial question with additional data (e.g., what you tried in between).

[EDIT 2017-07-31]: There is a Thunderbird problem that prevents "Send to > Mail recipient" function to work correctly (see e.g. TB release notes for 52.2.1, Known Issues). The workaround mentioned there is to install Microsoft Visual Studio 2015 redistributable runtime library or the Universal C Runtime for Windows Server. Maybe it's something related to this issue as well.

[EDIT 2018-03-09]: LibreOffice had used 8-bit MAPI to communicate with default mail provider; it also used original filename for temporary attachment files. With some of recent changes I made to the code (starting with this commit, followed by this, this, and this), it now uses 16-bit Simple MAPI, which eliminates some of problems that could result in such a message. Also, a problem code is now shown in the error message, to help determine the real problem. It will be available in version 6.1 (or using current dailies).

Specifically, this kind of problem could, among other reasons, be triggered when the document being sent contained some characters in name which couldn't be represented in current 8-bit Windows codepage. To check the problem, just create a simple file named "aбγ.odt" (i.e., containing Latin, Cyrillic, and Greek in the name - so cannot be represented in any Windows ACP), and try to sent it.

edit flag offensive delete link more

Comments

My solution on an old Windows XP box turned out be this (though I use operamail instead of TB):

Keep outlook as the default emailer. Make sure it's set up properly.

Note that during your testing of the Outlook Express configuration it may well give you authentication certificate errors. Accept the connection if you get such dialogs. Since I am presuming that Thunderbird uses TSL instead of SSL, this won't be a problem since most of the time you plan to use TB for the inbound stuff. TSL doesn't seem to suffer from the certificate issue the way SSL does.

In Outlook Express options disable the parts where it automatically checks for new messages upon launch, or at timed intervals.

Now you can still use TB as normal, but if you use the send as attachment email options in LiibreOffice it will find and use Outlook Express ...(plus)

Credo gravatar imageCredo ( 2020-04-22 23:17:27 +0200 )edit
0

answered 2017-07-08 12:44:59 +0200

Ezh gravatar image

Same problem here. Tb is the default mailing app on Win7, but LO fails to find it.

edit flag offensive delete link more

Comments

Thank you for this useful answer! It definitely helped the asker to solve the problem.

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-08 12:55:19 +0200 )edit

Thank you for answer. It works now

pekka.pasila@welho.com gravatar imagepekka.pasila@welho.com ( 2019-12-27 12:19:44 +0200 )edit
0

answered 2017-07-06 09:13:06 +0200

librebel gravatar image

Hello @jampjamp,

Please check if Thunderbird is set as the preferred email program in LibreOffice:

1. select the menu `"Tools  :  Options... :  Internet  :  E-mail"`
2. click the "Browse..." button to locate the Thunderbird program.
( on my Ubuntu the path is: /usr/bin/thunderbird )
edit flag offensive delete link more

Comments

I have this problem since upgrading to 6.0.7.3 on Linux Mint 19. Why does this suddenly not work? Yes, I can save the document in every format I want to send it in but that will just litter my hard drive. I have set claws-mail as my preferred email client in Mint settings and added /usr/lib/claws-mail in LO settings.

Please fix this Document Foundation!

sidestrand gravatar imagesidestrand ( 2019-01-18 18:14:09 +0200 )edit

... eight months later this is still not working

sidestrand gravatar imagesidestrand ( 2019-08-01 18:56:53 +0200 )edit

... ten months on and still not working. Also I cannot set up an email mail-merge. Can someone at LibreOffice take this seriously please? If the problem exists only for claws-mail it would be helpful to know that too. I tried the FlatPak version of LibreOffice today. It launched claws-mail when I tried 'send as email' but just that. No 'new mail' window opened and there was no evidence of a file being attached to anything.

sidestrand gravatar imagesidestrand ( 2019-10-28 16:41:03 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-06 08:35:18 +0200

Seen: 3,021 times

Last updated: Mar 09 '18