Ask Your Question
1

Calc are slow

asked 2017-07-25 15:16:11 +0200

jacek gravatar image

updated 2017-11-04 18:19:50 +0200

EasyTrieve gravatar image

LIbreOffice calc from the version 5.2 are very slow. In big spreadsheet this is not very comfortable. Any Ideas?

Regards Jacek

edit retag flag offensive close merge delete

Comments

Do you have a lot of search functions like VLOOKUP(), MATCH()?

m.a.riosv gravatar imagem.a.riosv ( 2017-07-25 23:47:14 +0200 )edit

no - I don't use this functions.

jacek gravatar imagejacek ( 2017-08-04 15:07:17 +0200 )edit

Which operating system and version are you running LibreOffice on?

paravantis gravatar imageparavantis ( 2017-08-08 08:51:32 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2018-03-15 14:32:35 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

edit flag offensive delete link more
0

answered 2017-08-04 01:45:14 +0200

Just-a-user gravatar image

You seem to be experiencing what I describe here. Have a look to see. I have come across several concerns for operating speed but they are not coordinated and none seem to get attention. If all our concerns are related, maybe this is a bigger problem.

edit flag offensive delete link more

Comments

Yes, this is the same poblem

jacek gravatar imagejacek ( 2017-08-04 15:06:33 +0200 )edit

Sounds like the same thing that I have found. Did not happen on 5.1, but on 5.3 is a problem.

SteveTX gravatar imageSteveTX ( 2017-08-16 20:42:45 +0200 )edit
0

answered 2017-11-17 23:05:22 +0200

Just resolved my same issue completely. If you do a custom install instead of the typical try uninstalling then reinstall using the typical option. That may clear it up. If not everything i did was uninstalled x64 custom install; installed x86 typical install; uninstalled; installed x64 typical. Was like night and day in performance. Seems either something doesn't get installed or the ui is looking for something in the languages i had unchecked for a leaner install.

edit flag offensive delete link more
0

answered 2017-11-17 01:44:31 +0200

Manipot gravatar image

For me, disabling the OPENGL worked.

Uncheck Tools/Options/Libre Office/View/Use OpenGL for all rendering

edit flag offensive delete link more

Comments

This worked for me as well. Calc was extremely slow, even with a blank spreadsheet open. Disabling OpenGL causes the program to run normally.

Bryandonwhite gravatar imageBryandonwhite ( 2017-12-05 11:30:02 +0200 )edit
0

answered 2018-10-25 11:33:34 +0200

laaneoks gravatar image

I turned off Tools => Options => LibreOffice => View => "Graphics Output" => "Use anti-aliasing". And also changed another values to "Small". I restarted LibreOffice and now my Calc table is quiet fast.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-07-25 15:16:11 +0200

Seen: 4,757 times

Last updated: Oct 25 '18