Ask Your Question

Missing "i" with font "Yanonone Kaffeesatz" [closed]

asked 2012-03-14 09:04:24 +0200

marc gravatar image

updated 2020-08-20 14:55:12 +0200

Alex Kemp gravatar image

When I try to print or export a writer file to PDF with the font Yanone Kaffeesatz ( the i's and ä's (german) are missing.

I'm using LibO 3.5.0 with Ubuntu 11.10 64bit.

The strange thing is that a friend had about the same problem with the newest version of Open Office on a Windows machine. It seems to be a problem with the font.

EDIT: The easiest way is sometimes the best. I reinstalled the TTF's and now it is working. Thanks for your help, guys.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-15 15:30:31.116379

3 Answers

Sort by » oldest newest most voted

answered 2012-03-14 16:52:44 +0200

cloph gravatar image

No problem with either of the two variants (TrueType and OpenType) of the fonts on linux, see attachment (PDF not in allowed attachments list, so screenshot only). Both PDFs were created with LibreOffice 3.5.0 on linux 64bit (Mageia). Yanone Font in exported PDF - no problems with Umlauts or i

So either the fonts are not installed correctly, or there is a problem outside of LibreOffice impacting the export. Please file a bug in launchpad (if you're using the version of LO provided by Ubuntu) and attach the sample document and the export-to-pdf result.

edit flag offensive delete link more

answered 2012-03-14 09:50:33 +0200

Alexander Wilms gravatar image

You should inform the one who's providing the font. LibreOffice can't do anything if the font is broken.

edit flag offensive delete link more

answered 2012-03-14 12:08:09 +0200

Pedro gravatar image

updated 2012-03-14 12:27:22 +0200

Using the Opentype version of Yanone Kaffeesatz Regular with LO 3.5.0 under Win XP produced a perfect PDF with all is and äs.
Try using the same text in another program and creating a PDF. If there are no errors then it is a LO bug under Linux and not a font problem. If the same letters are missing then it is a font problem.

Please report back

edit flag offensive delete link more


It is not working with either of the LO programs. 'Print to PDF' in GIMP is working. 'Save as PDF' in Inkscape has the same problem as LO. Seems to be a font problem then.

marc gravatar imagemarc ( 2012-03-15 11:25:35 +0200 )edit

Try the following: when exporting to PDF check the General PDF/A-1a option. This ensures that the font is embedded in the PDF and might solve your problem.

Pedro gravatar imagePedro ( 2012-03-15 11:30:50 +0200 )edit

Does not solve the problem.

marc gravatar imagemarc ( 2012-03-15 16:02:44 +0200 )edit

Question Tools


Asked: 2012-03-14 09:04:24 +0200

Seen: 421 times

Last updated: Mar 15 '12