Ask Your Question
3

Screen painting is slow, scrolling is over-aggressive, overall operation is slow and sometimes jerky

asked 2017-08-03 20:53:40 +0200

Just-a-user gravatar image

updated 2017-08-08 07:10:07 +0200

Screen painting is slow enough to be observed. Single, two or three mouse clicks on page-up and page-down areas on the scrollbar cause numerous page-up or page-down reactions, leading to scrolling well past the intended location and ongoing struggle to go to a desired location in Calc and Base (not Writer).

Just upgraded (using downloaded installers) from LibreOffice_5.2.3_Win_x86 to LibreOffice_5.3.4_Win_x64 (Version: 5.3.4.2 (x64), Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; Locale: en-US (en_US)). Operating system is Windows 7 64-bit. The prior version of LibreOffice was uninstalled before the newer version of LibreOffice was installed. I'm using a notebook computer with trackpad, all special features disabled except tap to click.

I had just started using Base with its native database engine and found scrolling to be over-aggressive. Clicking the scrollbar's line-down or line-up arrowhead worked fine, but a click or two (whether with the mouse's physical button or with a touchpad tap to click) on the scrollbar's page-up or page-down area would result in numerous page-up or page-down reactions, scrolling well past the intended destination, with scrolling taking place with significant delay. The database would often scroll near or to the bottom, or near or to the top. Navigation through the database was clumsy. Luckily, neither Calc nor Writer were affected.

So I upgraded to 5.3.4. Now screen painting is noticeably slow overall; Base continues to scroll over-aggressively as described; and Calc shows this type of over-aggressive scrolling, too. The overall slowdown feels sluggish, and gets especially bad when View > Data Sources is used to access a table from Calc, a table with about 100 records and 10 fields. Writer is slower to paint the screen, too, but it does not exhibit the over-aggressive scrolling behavior.

To get Calc to work faster I have started a new profile; I have unchecked the selection for using the Java runtime environment; I have increased the image cache to 512MB, memory per object to 15MB, and number of objects to 75 (I do not embed graphics in my documents or database); I have disabled OpenGL (later re-enabled it); I have allowed use of OpenCL (with and without OpenGL, later disabled it); and I have made sure not to start other applications. Slow screen painting and over-aggressive response to mouse page-up and page-down click events continue and no improvement is observed.

Screen painting is sufficiently slow that, when going through Tools > Options, you can watch the individually selected windows "unfurl", you can experience the window get populated with its UI elements. Graphics acceleration has been on throughout. Slow screen painting affects Calc throughout its operation. It also has an observable effect on Writer. Applications other than those in LibreOffice are not affected.

What would you like me to try to help isolate the cause? What can I do to restore the speed of screen painting speed of LibreOffice 5.2 ... (more)

edit retag flag offensive close merge delete

14 Answers

Sort by » oldest newest most voted
0

answered 2017-09-27 14:14:15 +0200

Ji-Ef gravatar image

Just upgraded to 5.4.1 (also tested 5.4.2 from testing/) and I also experience lots of slowness on Windows 10, from the scrolling to the overall UI.

All of this does not happen on a old 32bits WinXP computer (AMD Sempron & Nvidia onboard GPU)

Windows 10 is 64bits, on an Intel Core i5, 6GB of RAM, onboard Intel GPU and dedicated nVidia Graphic Card (9600GT) (can't update drivers anymore as the product is no longer maintained)

Tested LibO installer 32 and 64bits on Windows 10, both on nVidia and Intel GPU, with and without OpenGL, it's all the same slowness, both on scrolling and overall UI. LinO 5.2.7 and 5.3.6 seems to work ok, but not as snappier as on WinXP.

Could it be a problem with that composite thing (dwm?) on Windows 10 ? If it could be disabled...

edit flag offensive delete link more
0

answered 2017-10-31 17:18:46 +0200

Frank Lekens gravatar image

I have the same problem, I think. Just updated from 5.xxsomething to 5.4.2.2. Scrolling is really weird.

I do have an nVidia graphics card, but I don't understand the advice in the last post. Is there an option in LibreOffice that where you can specify if it should use the graphics driver or not?

(NB: nothing on my graphics driver was updated. It was just LO that was updated and then this started. The previous version didn't seem to have this problem.)

edit flag offensive delete link more
0

answered 2017-11-02 02:02:18 +0200

GregS gravatar image

Not sure what version I was on (it was V5 though), but I've just upgraded to 5.3.6.1 (X64), and I now have the same problem. System: Windows 10-X64, Dell M4500 laptop (quad core i5 2.53GHz), 4GB, nVidia Quadro FX880M

edit flag offensive delete link more
0

answered 2017-11-02 18:14:08 +0200

maje90 gravatar image

updated 2017-11-02 18:22:26 +0200

Hi all.

Got the same problem in 2 workstations, extremely slow with basics scrolling. OpenCL/GL or antialiasing on/off... no difference. I were on 5.4.1 now i installed 5.4.3.1 (testing version), with OpenGL off everything is smooth as it should be. Disisntalled and installed without rebooting windows (10).

edit flag offensive delete link more
0

answered 2017-11-01 16:04:46 +0200

LC gravatar image

Steps:

  1. open LibreOffice (soffice.exe)
  2. open the File menu (Alt + F)
  3. press and keep pressed the Down arrow

The menu selection will cycle through the menu items of the File menu, however this very simple action will already use ~70% of a single i7 CPU core clocked at 3.2 GHz.

This can be reproduced both in normal and in safe mode, with and without anti-aliasing, with and without hardware acceleration, with and without OpenGL.

Configuration: LibreOffice 5.4.2.2 (x64) on Windows 10 x64 (GPU: Nvidia GTX 1060 (mobile), integrated graphics is disabled)

edit flag offensive delete link more
0

answered 2018-01-10 09:35:58 +0200

cpy gravatar image

updated 2018-01-10 09:36:22 +0200

Is it fixed? Currently I'm on Version: 5.2.7.2 (x64) and it works like magic. I have same problem with newer version too.

edit flag offensive delete link more
0

answered 2018-04-17 14:14:11 +0200

black listing opengl completely solve my problem, although 4.2 version is still rocket fast then 5.4

all following entry to share/opengl/opengl_blacklist_windows.xml

<entry os="all" vendor="all"> <device id="all"/> </entry>

edit flag offensive delete link more
0

answered 2017-11-11 03:37:02 +0200

Steve Pike gravatar image

updated 2017-11-12 20:31:04 +0200

Back in July 2017, after upgrading LO 5.2.7 (x32) to 5.3.4 (x64), I noticed a pronounced lag in Calc when scrolling up or down a spreadsheet. There was also a significant lag when doing a large copy/paste operation into a spreadsheet. I thought more RAM might help, so I added 4GB more (8GB total), but still no joy.

Today I upgraded to LO 5.4.3.2 (x64) and the slowness problem has finally been resolved! Woo-hoo!

edit flag offensive delete link more
0

answered 2017-08-04 15:08:56 +0200

jacek gravatar image

I have this same problem (this sescribe)

edit flag offensive delete link more
0

answered 2017-08-20 12:59:01 +0200

MrCos gravatar image

updated 2017-08-21 13:05:46 +0200

I have the same problem with Calc version 5.4.0 but using and old version, 5.2.6 portable, speed is as expected. I have windows 10 with AMD athlon X4 and NVIDIA GTX650 graphics card.

Edit:

I tried in another computer. HP laptop core i5 with Intel display adaptor and similiar results. I tried 4 versions:

Versión: 5.2.2.2 Id. de compilación: 8f96e87c890bf8fa77463cd4b640a2312823f3ad Subprocesos de CPU: 4; Versión de SO: Windows 6.2; Renderizado de IU: predeterminado; Configuración regional: es-ES (es_ES); Calc: group

Versión: 5.3.4.2 Id. de compilación: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 Subproc. CPU: 4; SO: Windows 6.2; Repres. IU: GL; Motor de trazado: HarfBuzz; Configuración regional: es-AR (es_ES); Calc: group

Versión: 5.4.0.3 Id. de compilación: 7556cbc6811c9d992f4064ab9287069087d7f62c Subproc. CPU: 4; SO: Windows 6.2; Repres. IU: GL; Configuración regional: es-AR (es_ES); Calc: group

Versión: 5.4.0.3 (x64) Id. de compilación: 7556cbc6811c9d992f4064ab9287069087d7f62c Subproc. CPU: 4; SO: Windows 6.19; Repres. IU: predet.; Configuración regional: es-ES (es_ES); Calc: group

And both 5.4.0.3 versions are much slower than previous versions when I press av. pag.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

4 followers

Stats

Asked: 2017-08-03 20:53:40 +0200

Seen: 5,894 times

Last updated: Apr 17 '18