Calc are slow

LIbreOffice calc from the version 5.2 are very slow.
In big spreadsheet this is not very comfortable.
Any Ideas?

Regards Jacek

Do you have a lot of search functions like VLOOKUP(), MATCH()?

no - I don’t use this functions.

Which operating system and version are you running LibreOffice on?

You seem to be experiencing what I describe here. Have a look to see. I have come across several concerns for operating speed but they are not coordinated and none seem to get attention. If all our concerns are related, maybe this is a bigger problem.

Yes, this is the same poblem

Sounds like the same thing that I have found. Did not happen on 5.1, but on 5.3 is a problem.

For me, disabling the OPENGL worked.

Tools/Options/Libre Office/View/Use OpenGL for all rendering

This worked for me as well. Calc was extremely slow, even with a blank spreadsheet open. Disabling OpenGL causes the program to run normally.

Just resolved my same issue completely. If you do a custom install instead of the typical try uninstalling then reinstall using the typical option. That may clear it up. If not everything i did was uninstalled x64 custom install; installed x86 typical install; uninstalled; installed x64 typical. Was like night and day in performance. Seems either something doesn’t get installed or the ui is looking for something in the languages i had unchecked for a leaner install.

i solved here calc suddenly runs very slowly

I turned off Tools => Options => LibreOffice => View => “Graphics Output” => “Use anti-aliasing”. And also changed another values to “Small”.
I restarted LibreOffice and now my Calc table is quiet fast.