How to stop CPU spinning when saving file with large linked images?

asked 2017-08-16 11:52:56 +0100

chewywater gravatar image

updated 2017-08-16 21:11:13 +0100

Problem: CPU spins when saving odt files that link to images that have large dimensions (not necessarily large storage size).

TO REPRODUCE

I've made a few images whose widths and heights are very large, but whose storage size is small. They are linked below. If anyone wants to try to reproduce my problem:

  • download one of the images listed below
  • open a new writer doc
  • tools menu>options>writer>view>turn off display of images.
  • insert the image by link (I've been doing this with ctrl-shift-drag)
  • in the document, copy and paste the linked pic multiple times.
  • Try to save the file. Let me know if there's an image large enough, copied enough times, that sets your cpu spinning when you try to save.

5k pixels per side 82k

https://drive.google.com/file/d/0B_45...

10k pixels per side 309k

https://drive.google.com/file/d/0B_45...

20k pixels per side 1MB

https://drive.google.com/file/d/0B_45...

My setup

Libre Office Version: 5.4.0.3 Build ID: 1:5.4.0~rc3-0ubuntu0.14.04.1~lo2 OS: LXLE (lubuntu/ubuntu) Ubuntu 14.04.5 LTS Processor: 2x Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz Memory 2 Gig

edit retag flag offensive close merge delete

Comments

I'd like to note that this theme is already discussed on https://forum.openoffice.org/en/forum.... Probably LibreOffice reacts in another way as OpenOffice?

Grantler gravatar imageGrantler ( 2017-08-16 21:25:55 +0100 )edit