Ask Your Question
1

why is soffice.bin using 60% CPU with nothing open?

asked 2017-08-30 14:57:11 +0200

docsmooth gravatar image

Kubuntu 17.04, when I click "LibreOffice" from the menu, it opens, and immediately begins to consume 60% CPU on a 4-core i5 indefinitely, at the splash screen, if I click new blank document... If I open one of my standard 8 page white papers, it goes up higher. This prevents me from using LibreOffice on battery, especially when Word in wine uses LESS overall energy with a 16 page document than soffice on the splash screen

$ ps -eo stime,pcpu,time,comm |egrep '([s]office|WINWORD)' 09:33 32.5 00:30:16 WINWORD 10:35 69.5 00:21:32 soffice

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-09-28 23:56:42 +0200

updated 2019-09-28 23:58:09 +0200

No idea why it's happening, but it's bothering me like crazy too. Meanwhile, here's a workaround:

  1. SAVE ALL YOUR OPEN DOCUMENTS.
  2. Then, with them still open, go to a terminal and type pkill soffice.bin. This kills the out-of-control process.
  3. Re-open LibreOffice. Let it auto-recover your open documents, and you can now continue working.

You may have to do this every time you have the problem. It's not a permanent fix.

Here's a screenshot showing before doing pkill, and after. Note that even after reopening libreoffice after doing the pkill command, my CPU usage still stayed very low just like it's shown here at the right. In other words, reopening libreoffice did NOT cause the bad CPU behavior again.

image description

Related:

  1. Bug report: go click the little button at the top to indicate you have this problem too (the button is next to where it says "This bug affects you and __ other people": https://bugs.launchpad.net/ubuntu/+so...
  2. Potential fix: http://webnetkit.com/soffice-bin-usin...; you can find your location of the sofficerc file with: sudo find / | grep sofficerc
  3. https://ask.libreoffice.org/en/questi...
  4. https://serverfault.com/questions/953...
edit flag offensive delete link more

Comments

Hello,

Personally don't see this problem. Have run LO for years now. Most of the installs were from TDF (The Document Foundation. Currently on Ubuntu 18.04 Mate with LO 6.3.2.2 on 4 core 8 thread machine just now opened many .odt docs and the highest core usage was 23% briefly. Had Mint 18.3 Cinnamon also and no high CPU problems noted there either.

The largest document was 49 pages with a number of embedded images. With the document open, hardly see any CPU usage even with modifying the document. Did a save and one thread jumped to 8% for a second or two.

Ratslinger gravatar imageRatslinger ( 2019-09-29 03:36:40 +0200 )edit

three observations:

  • calc without data: no load,

  • calc with opened sheets: sometimes irregular load, especially in files with comments, especially in linux ver., especially after autosave or 'save as',

  • ver. 6.2.7.1 under win best yet seen version reg. this load and resulting slowdowns,

  • still has - very rare - err:522 after inserts in large sheets when set to 'threaded' calculations,

    • not observed in 'unthreaded' mode,

reg.

b.

newbie-02 gravatar imagenewbie-02 ( 2019-10-09 16:17:01 +0200 )edit
0

answered 2019-09-29 10:55:25 +0200

frankvw gravatar image

I'm still having the problem of LO using 100% on one CPU core quite frequently. I have observed the following details though:

  1. Ercaguy's method as described above (close all documents, then kill the LO process) works but, as he says, it's only a temporary fix;

  2. The problem occurs more frequently when I have LO Calc spreadsheets open among other LO documents, OR when I have a REALLY large LO Writer document open;

  3. The problem occurs mostly after resuming from sleep mode.

I'm running LO 6.0.7.3 on Ubuntu 18.04, installed from the repositories.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-08-30 14:57:11 +0200

Seen: 985 times

Last updated: Sep 29 '19