Ask Your Question
1

pasting problem [closed]

asked 2013-02-26 11:26:38 +0200

ajyoung gravatar image

updated 2015-09-12 01:28:32 +0200

Alex Kemp gravatar image

I'm using Windows XP SP3 and LibreOffice 4 and I'm experiencing problems when pasting to Writer.

After doing several copy/paste work, for this example, let's us say I've successfully copied and pasted 5 times, on the 6th copy function, pasting into Writer will paste the selection from the previous copy (the 5th copy).

However, if I test pasting into notepad or wordpad, the selection from the 6th copy pastes just fine. But in Writer, it's clipboard is somehow stuck on the previous (5th) copy.

Even if I do several more copy functions (7th, 8th, 9th selection copy), pasting into Writer will always paste the 5th selection copied.

I have tried searching for postings of problems similar to this hoping that there is already a solution, but to no avail. So, I'm hoping someone here can help me.

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 17:05:20.920915

Comments

I have a solution - at least for my instance. I also was getting a problem with pasting the previous item copied to the clip board. Closing and opening Libre Calc solved it for a few instances and the it stopped pasting between Firefox and Libre completely. It would work to paste to a text editor - which would clear the clip board. After reading the list here - I started closing programs. I had opened Freemaker Video Converter and had not closed it. Once closed, the problem went away.

prouser gravatar imageprouser ( 2015-12-25 03:50:58 +0200 )edit

14 Answers

Sort by » oldest newest most voted
1

answered 2013-03-11 03:31:29 +0200

ajyoung gravatar image

Thank you all for your response. Just received the notification that there was activity on my post so my apologies for this late reply.

To answer @horst, we are not using any external or third-party clipboard software.

I have to point out that what we copy and paste are not just words or phrases. We copy several long paragraphs from a desktop publishing software (namely InDesign) to a text editor (in this case, LibreOffice Writer).

Our staff usually highlights everything, including pictures, and paste it into Writer. Copy-and-paste function works fine for several iterations but then at one point it will just repeat pasting a single copied instance (in my example, the 5th copied item).

It looks to me like it's not flushing out the internal clipboard (not the Windows clipboard because pasting to Notepad, for example, pastes the correct copy as mentioned in my initial report).

This was happening in ver3.x and we thought would be fixed in ver4. Is there a way perhaps to flush/reset the internal clipboard of LibreOffice? We scoured the options settings but could not find any way to do this.

edit flag offensive delete link more

Comments

@ajyoung -- Given that we're not able to reproduce the bug, it's possible that it's some weird interaction that's only being exercised on your system(s).

I suggest you go ahead and file a bug (see link in my Answer) and explain everything that we've discussed on the Question up to this point. The QA team can hopefully work with you to find the source of this issue.

qubit gravatar imagequbit ( 2013-03-11 09:12:39 +0200 )edit
1

@qubit - Filed the bug as you suggested. I forgot to check what the bug tracking number is so I can't post it. Is there a way to view the bug submitted or check for feedback?

ajyoung gravatar imageajyoung ( 2013-03-13 03:31:30 +0200 )edit

Hi @ajyoung, Looks like your bug is here:

fdo#62196 - EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents - NEEDINFO

Please provide additional information per @rrbd's request.

Thanks!

qubit gravatar imagequbit ( 2013-03-13 03:59:54 +0200 )edit

@ajyoung -- Regarding finding bugs you've filed on Bugzilla, just log-in and look for a link "My Bugs" that's down at the bottom of the page.

Cheers,

qubit gravatar imagequbit ( 2013-03-13 04:03:35 +0200 )edit
1

@qubit - found it! fdo#62196

ajyoung gravatar imageajyoung ( 2013-03-13 04:42:14 +0200 )edit

fdo#62196 · Status: NEEDINFO

manj_k gravatar imagemanj_k ( 2013-03-20 11:02:37 +0200 )edit

@ajyoung, I'd like to resolve this question as 'BUG FILED' -- is that okay with you?

Thanks!

qubit gravatar imagequbit ( 2013-03-23 21:31:48 +0200 )edit

fdo#62196 · Status: NEW

manj_k gravatar imagemanj_k ( 2014-07-29 23:22:55 +0200 )edit
2

answered 2013-03-23 20:23:16 +0200

Another Dave gravatar image

updated 2013-03-23 20:24:22 +0200

Just want to report that I'm having exactly the same problem:

LibreOffice 4.0.0.3

Windows XP Pro

Can't paste from external apps into Writer using Ctrl-V or menu/edit/paste.

Can paste from Writer to external apps.

Can drag text into Writer.

Problem persists after closing Writer down and restarting it.

However, I am running QuickStarter. If I close QuickStarter then run up Writer, I can copy into Writer from an external app until I copy something to the clipboard in Writer. From that point it will only paste what I copied in writer. Except that at some point later (and I can't figure out the cause) it will occasionally work.

It's as if Writer respects the clipboard until something is put into it from Writer. At that point it's anyone's guess as to whether or when it will work again.

I do have Clipboard Fusion installed, but these problems occur regardless of whether it is running or not.

edit flag offensive delete link more

Comments

@Another Dave, Hi -- looks like @rrbd marked the filed bug as NEEDINFO. Could you please provide the needed information so that we can get the bug into a position where we can hand it over to the developers?

Thanks!

qubit gravatar imagequbit ( 2013-03-23 21:32:49 +0200 )edit

Sorry, bit of a noob here. Can't see NEEDINFO anywhere, or rrdb response to my comment. Are you referring to this: https://bugs.freedesktop.org/show_bug.cgi?id=62196#c1

Another Dave gravatar imageAnother Dave ( 2013-03-23 23:21:05 +0200 )edit
2

answered 2013-03-15 20:22:32 +0200

bigb gravatar image

The exact same thing happens to me on Windows 8, LibreOffice Writer Version 4.0.0.3 I can copy and paste text with CTRL-C and CTRL-V many times then all of a sudden CTRL-V will only paste the previous item copied to the paste buffer, not the current item. I open a text editor and CTRL-V works perfectly, pasting the current item. If I exit out of LibreOffice Writer and reopen the document I can use CTRL-V immediately to paste in the current clipboard item.

edit flag offensive delete link more

Comments

@bigb -- That information would be great to have included on the bug report. Could you put the information there? (it would help us to have you post the information, so the devs would know that you can be a contact for repro/testing on the bug.

Thanks!

qubit gravatar imagequbit ( 2013-03-23 21:34:59 +0200 )edit
1

answered 2013-02-26 17:07:49 +0200

horst gravatar image

Tried to reproduce it in LO4.0.0.3 under Win7 64bit. Everything worked fine.

Do you use an external clipboard that might not work well with Writer?

I have no WinXP box available may be @ROSt52 can test it.

edit flag offensive delete link more

Comments

@jmadero.dev tested this under XP and said he couldn't repro it either.

qubit gravatar imagequbit ( 2013-02-26 17:36:47 +0200 )edit
1

answered 2013-02-27 02:49:47 +0200

ROSt52 gravatar image

As @horst suggested, I made a test using Version 3.6.5.2 (Build ID: 5b93205) on XPprof /SP3 Asian language support

I created 10 character strings in Writer and copied and pasted each of them one after the other. I used the mouse to select and ctrl+c and ctrl+ v to copy and paste

No problem seen in above test. In general I never observed this problem even when copying across application in Libo or from outside LibO into LibO.

I feel @qubit is right. It looks like weird bug.

edit flag offensive delete link more
0

answered 2014-02-14 12:37:21 +0200

Gortys gravatar image

This copy/paste error happens to me as well.

It's been around since the start of version 4.

Clipboard fusion is not the problem, since this error occurs with it not installed. But with it installed, there is a work around, right click on clipboard fusion icon, goto clipboard history and select what you just copied. This will then let you paste it in the Calc or Write apps.

The only other option, is the one I'm using now, fall back to a none version 4.X.X.X LibreOffice/OpenOffice. I'm using version 3.6.5.2 LibreOffice and everything works fine, even with clipboard fusion installed.

cheers

edit flag offensive delete link more
0

answered 2014-02-27 14:26:46 +0200

salem gravatar image

Had the same problem. No Libreoffice program would let me copy text into the clipboard. What you can do is start the windows task manager and end background processes one at a time, re-open the file with libreoffice and try to copy and paste a piece of text from it to notepad for example, and see after which ended process it starts working again. For me it was the process kleopatra.exe, which is an encryption software that was causing the problem. Cheers.

edit flag offensive delete link more
0

answered 2013-03-23 19:21:30 +0200

librenomtat gravatar image

updated 2013-03-23 19:27:39 +0200

This has been plaguing me literally for years, but until the latest Libre and Windows 8 it was only a considerable annoyance. (I assumed it was a Windows problem, very, very foolishly, 'cause I believed in open source. I was even stupid enough to imagine that maybe Microsoft was sabotaging Open Office, since they have done similar things in the past.)

Now cut and paste is a catastrophe, and I will be leaving the Libre and Open Office world. I installed Word yesterday, and will probably use it with rtf for all files. Sadly I had to abandon .rtf some years ago because OO used to choke on it in large files. So now I have non-standard file types (as far as word and the world go.) No .rtf fix ever came because that issue was declared a non-problem. I should have abandoned Open Office then.

I've researched and tried a dozen clipboard reset "solutions" yesterday and today (rather than working - total up the cost for that) and none worked for more than one paste - then the problem recurs. Rebooting, CCleaner, endless other tries. I have managed to prove to myself that it's Libre, not Windows. Changing computers hasn't worked. Changing to Libre hasn't worked. Changing OSes hasn't worked. So goodbye cruel Libre.

(For God's sake, at least make it possible for users to quickly, genuinely, clear the internal clipboard, or permanently disable it in favor of the OS clipboard, if that's possible.)

My experience with OO and now Libre is that programmers are very quick to decide there can't be a problem or that it's "weird" and a one-off. I sympathize, because I understand there aren't infinite resources; so dismissing problems that aren't trivially reproducible is quite tempting: but some few functions just HAVE to work for even the most basic functionality, and cut and paste is one of those. There are a few functions that have to be genuinely robust, period. Without a recognition of this most users end up back in a virtual Soviet Union, endlessly lining up for bread and sausages (that is, bug fixes) in front of shops with always empty shelves.

I believed in open software but now I've simply been bitten too many times. I'll be dumping GIMP for Corel or similar in the next day or so as well ... (more)

edit flag offensive delete link more
0

answered 2013-02-26 16:30:35 +0200

qubit gravatar image

updated 2013-02-26 16:30:59 +0200

Hi @ajyoung,

That sounds like a very weird bug! It sounds like you're already running the latest release, so please file a bug and provide a list of steps that can reproduce your problem (the description you have above looks like a great start! :-).

The QA team will be happy to help you track down this issue! Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Comments

(noting bug here for resolution purposes)

fdo#62196 - EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents

qubit gravatar imagequbit ( 2013-03-13 04:45:58 +0200 )edit
0

answered 2013-03-04 16:26:10 +0200

I have exactly the same set up and problem, but am also using "Phrase Express" (www.phraseexpress.com). If I turn off the clipboard cache in Phrase Express the problem seems to go away. I'll try it for a while longer to confirm...

edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2013-02-26 11:26:38 +0200

Seen: 16,430 times

Last updated: Feb 27 '14