Pasting problem

I’m using Windows XP SP3 and LibreOffice 4 and I’m experiencing problems when pasting to Writer.

After doing several copy/paste work, for this example, let’s us say I’ve successfully copied and pasted 5 times, on the 6th copy function, pasting into Writer will paste the selection from the previous copy (the 5th copy).

However, if I test pasting into notepad or wordpad, the selection from the 6th copy pastes just fine. But in Writer, it’s clipboard is somehow stuck on the previous (5th) copy.

Even if I do several more copy functions (7th, 8th, 9th selection copy), pasting into Writer will always paste the 5th selection copied.

I have tried searching for postings of problems similar to this hoping that there is already a solution, but to no avail. So, I’m hoping someone here can help me.

Thanks in advance!

I have a solution - at least for my instance. I also was getting a problem with pasting the previous item copied to the clip board. Closing and opening Libre Calc solved it for a few instances and the it stopped pasting between Firefox and Libre completely. It would work to paste to a text editor - which would clear the clip board. After reading the list here - I started closing programs. I had opened Freemaker Video Converter and had not closed it. Once closed, the problem went away.

The exact same thing happens to me on Windows 8, LibreOffice Writer Version
I can copy and paste text with CTRL-C and CTRL-V many times then all of a sudden CTRL-V will only paste the previous item copied to the paste buffer, not the current item. I open a text editor and CTRL-V works perfectly, pasting the current item. If I exit out of LibreOffice Writer and reopen the document I can use CTRL-V immediately to paste in the current clipboard item.

@bigb – That information would be great to have included on the bug report. Could you put the information there? (it would help us to have you post the information, so the devs would know that you can be a contact for repro/testing on the bug.


Just want to report that I’m having exactly the same problem:


Windows XP Pro

Can’t paste from external apps into Writer using Ctrl-V or menu/edit/paste.

Can paste from Writer to external apps.

Can drag text into Writer.

Problem persists after closing Writer down and restarting it.

However, I am running QuickStarter. If I close QuickStarter then run up Writer, I can copy into Writer from an external app until I copy something to the clipboard in Writer. From that point it will only paste what I copied in writer. Except that at some point later (and I can’t figure out the cause) it will occasionally work.

It’s as if Writer respects the clipboard until something is put into it from Writer. At that point it’s anyone’s guess as to whether or when it will work again.

I do have Clipboard Fusion installed, but these problems occur regardless of whether it is running or not.

@AnotherDave, Hi – looks like @rrbd marked the filed bug as NEEDINFO. Could you please provide the needed information so that we can get the bug into a position where we can hand it over to the developers?


Sorry, bit of a noob here. Can’t see NEEDINFO anywhere, or rrdb response to my comment.
Are you referring to this:

Tried to reproduce it in LO4.0.0.3 under Win7 64bit. Everything worked fine.

Do you use an external clipboard that might not work well with Writer?

I have no WinXP box available may be @ROSt53 can test it. tested this under XP and said he couldn’t repro it either.

As @horst suggested, I made a test using Version (Build ID: 5b93205) on XPprof /SP3 Asian language support

I created 10 character strings in Writer and copied and pasted each of them one after the other. I used the mouse to select and ctrl+c and ctrl+ v to copy and paste

No problem seen in above test. In general I never observed this problem even when copying across application in Libo or from outside LibO into LibO.

I feel @qubit1 is right. It looks like weird bug.

Thank you all for your response. Just received the notification that there was activity on my post so my apologies for this late reply.

To answer @horst, we are not using any external or third-party clipboard software.

I have to point out that what we copy and paste are not just words or phrases. We copy several long paragraphs from a desktop publishing software (namely InDesign) to a text editor (in this case, LibreOffice Writer).

Our staff usually highlights everything, including pictures, and paste it into Writer. Copy-and-paste function works fine for several iterations but then at one point it will just repeat pasting a single copied instance (in my example, the 5th copied item).

It looks to me like it’s not flushing out the internal clipboard (not the Windows clipboard because pasting to Notepad, for example, pastes the correct copy as mentioned in my initial report).

This was happening in ver3.x and we thought would be fixed in ver4. Is there a way perhaps to flush/reset the internal clipboard of LibreOffice? We scoured the options settings but could not find any way to do this.

@ajyoung – Given that we’re not able to reproduce the bug, it’s possible that it’s some weird interaction that’s only being exercised on your system(s).

I suggest you go ahead and file a bug (see link in my Answer) and explain everything that we’ve discussed on the Question up to this point. The QA team can hopefully work with you to find the source of this issue.

@qubit1 - Filed the bug as you suggested. I forgot to check what the bug tracking number is so I can’t post it. Is there a way to view the bug submitted or check for feedback?

Hi @ajyoung, Looks like your bug is here:

fdo#62196 - EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents - NEEDINFO

Please provide additional information per @rrbd’s request.


@ajyoung – Regarding finding bugs you’ve filed on Bugzilla, just log-in and look for a link “My Bugs” that’s down at the bottom of the page.


@qubit1 - found it! fdo#62196

fdo#62196 · Status: NEEDINFO

@ajyoung, I’d like to resolve this question as ‘BUG FILED’ – is that okay with you?


fdo#62196 · Status: NEW

Hi @ajyoung,

That sounds like a very weird bug! It sounds like you’re already running the latest release, so please file a bug and provide a list of steps that can reproduce your problem (the description you have above looks like a great start! :-).

The QA team will be happy to help you track down this issue! Please post a link to any bugs you file in a comment below using the format “fdo#123456”.