Ask Your Question
0

Cannot add records to a database [closed]

asked 2013-02-27 17:02:17 +0200

betahawk gravatar image

Hey all,

When I'm looking at a database in Data View, there is no way for me to add a record or edit existing records. If I click "Insert > " the Record option is grey and not available to click.

If I "edit" the database in "Table Design" all I see is the Field Name/Field Type.

Is there anyway I can just open the data and update it manually like in Access?

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-25 05:44:54.671892

Comments

@Ramne, I have a primary key associated with an ID field and I'm still unable to edit anything in the database.

betahawk gravatar imagebetahawk ( 2013-03-01 16:21:32 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-03-01 16:45:59 +0200

betahawk gravatar image

I fixed my problem. I think something went wrong when I imported my database from Access. I created a new database and within the new database I could edit the tables just fine.

edit flag offensive delete link more
0

answered 2013-02-27 21:19:33 +0200

Ramne gravatar image

I think you lack an id-column. This column must have unique values. Select the table, right click and Edit. Now, either let an existing column be the tables id by right-click in the field left to "Fieldname" and choose Primary key, or create a new field to be your Primary key.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-27 17:02:17 +0200

Seen: 8,621 times

Last updated: Mar 01 '13