Ask Your Question
1

Why does the Excel Macro "Windows("Data1.xls").Activate" not work in LibreOffice [closed]

asked 2013-03-04 16:19:58 +0100

Ken W gravatar image

updated 2015-10-26 21:53:43 +0100

Alex Kemp gravatar image

Why does the Excel Macro "Windows("Data1.xls").Activate" not work in LibreOffice.

I believe that I attached the files so you can look at the Macro. When I create the Macro in LibreOffice, the Macro Language looks completely different than when I create it in Excel. I'm just starting to experiment in LibreOffice. Is there a way to have the Macro Language look similar to the Excel Language? Error Image another try at image

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-26 21:54:28.893104

2 Answers

Sort by » oldest newest most voted
0

answered 2013-03-15 02:28:03 +0100

qubit gravatar image

@Ken W,

I found a similar question on the Ubuntu Forums. Their macro code includes this familiar bit:

REM # Activate the original excel sheet
Windows("Darts_Grab.xls").Activate

User Hagar Delest explained:

The macro language depends on the application and VBA cannot be completely implemented in other applications.

Either rewrite your macros in OOo/LO/AOO Basic or better, chose another language. Python is often advised on the AOO English forum.

I'm not sure about that .Activate function specifically. There might be some info here:

edit flag offensive delete link more

Comments

Thanks for the suggestion. I quickly tried it and it did not work. I have a busy schedule so I will try digging into it in the upcoming weeks.

Ken W gravatar imageKen W ( 2013-03-25 22:39:17 +0100 )edit

@Ken W, I'm not sure what you quickly tried, but good luck with translating your VBA to LibreBasic :-)

qubit gravatar imagequbit ( 2013-03-26 00:55:35 +0100 )edit
0

answered 2013-03-04 22:24:31 +0100

qubit gravatar image

Hi @Ken W,

Are you talking about a particular file that contains certain macros? Please upload an example file so we can take a look at it.

Thanks!

edit flag offensive delete link more

Comments

I attached two files. Or at least I think I did. I can not tell if they are there for you or not.The DataGathered file has the macro. Thanks for looking into this for me.

Ken W gravatar imageKen W ( 2013-03-07 15:35:21 +0100 )edit

@Ken W -- I'm not seeing a link to any files. Did you use the paperclip icon to open the file-upload dialog?

qubit gravatar imagequbit ( 2013-03-07 21:05:34 +0100 )edit

I used the paperclip icon to add the files. I can not tell if they attached or not. I did it again this morning and I still can not tell if they are added. My e-mail address is Ken.Wraspir@3dcnc.com. If you want to e-mail me, I can send you the files that way.

Ken W gravatar imageKen W ( 2013-03-08 16:53:07 +0100 )edit

@Ken W -- we did have some trouble in the past with uploads from certain browser/OS combinations. What are you running on your machine?

qubit gravatar imagequbit ( 2013-03-08 18:06:00 +0100 )edit

Windows Internet Explorer9 Version 9.0.8112.16421 with Windows 7 Professional Service Pack 1 64-bit Operating System

Ken W gravatar imageKen W ( 2013-03-08 18:59:36 +0100 )edit

@Ken W -- let me try to rustle-up someone who can test on that config.

qubit gravatar imagequbit ( 2013-03-08 19:11:46 +0100 )edit

I tried a copy things and still have the same problems. Any luck on your end?

Ken W gravatar imageKen W ( 2013-03-14 21:47:24 +0100 )edit

@Ken W -- Sorry, I haven't found anyone with Win7-64bit. I'm still not seeing your files available for download (I see the start of some links, but there are no viable urls there)

qubit gravatar imagequbit ( 2013-03-14 22:56:43 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2013-03-04 16:19:58 +0100

Seen: 1,518 times

Last updated: Mar 15 '13