Ask Your Question
1

Table of Content [closed]

asked 2013-03-07 10:14:06 +0100

Huskey gravatar image

updated 2013-06-12 19:29:18 +0100

manj_k gravatar image

Hi

I've created a table of content in a Writer document. Nothing happens when I ctrl + click on an entry. How can I activate ctrl + click to jump to the relevant section in the document?

Many thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-26 15:19:03.234762

Comments

1

Works for me. How exactly did you make your table of contents? Was it kind of automatic? Did you use header styles? What exact version do you use?

mahfiaz gravatar imagemahfiaz ( 2013-03-07 11:29:14 +0100 )edit

Leave all Other Idea THere Is Best Thing For table of content management just Check It Out This site

http://index-indent-online.com/

All Solution of table of content issue here!!

shashank gravatar imageshashank ( 2018-03-18 10:32:27 +0100 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2013-03-08 09:30:16 +0100

mahfiaz gravatar image

Your document's table of contents is missing hyperlink start and end tags.

To add these back

  1. right click on your table of contents
  2. select edit register/TOC
  3. click entries tab
  4. put cursor to the first place under structure
  5. click hyperlink, it adds link start marker
  6. put curstor to the last place under structure
  7. click hyperlink again, now it adds link end marker

And now you should be all good.

To make sure there is no bug involved, please create a new document, add a few headers, add a TOC and see if there are links. If they are, everything is fine. If they are not links, it might be that German version of LibreOffice needs fixing. Please report it then.

edit flag offensive delete link more

Comments

2

If you want hyperlinks for all levels of the TOC then after step 7 click on the "All" button above the Hyperlink button.

w_whalley gravatar imagew_whalley ( 2013-03-08 15:19:12 +0100 )edit
1

Everything works fine now. Created also TOC in a new document. Works fine without adjustments. But I'm using LO's English (US) version. Many thanks for all your help.

Huskey gravatar imageHuskey ( 2013-03-08 20:23:04 +0100 )edit

Glad you got it sorted out. Then this document is either 1) very old, 2) imported from doc or some other program or 3) someone intentionally removed these links.

Another possibility to "fix" this and many other strange problems with document settings is to copy whole text and paste it into a brand new document.

mahfiaz gravatar imagemahfiaz ( 2013-03-09 16:32:20 +0100 )edit
0

answered 2013-03-07 23:34:03 +0100

Huskey gravatar image

Here we go. I've shortened the document. Hopefully you can reproduce the issue.

Thanks.Test.odt

edit flag offensive delete link more
0

answered 2013-03-07 21:45:40 +0100

Huskey gravatar image

Honestly, I can't remember when and what version it was but I clearly remember it was the automatic one, header style, only 2 levels, i.e. Heading 1 and Heading 2. And when I add a heading and click on Update Index/Table, task is performed smoothly. Currently I use LO 4.01.

Thanks for your help.

edit flag offensive delete link more

Comments

@Huskey, If you can upload your document (remove any private/personal information first), we can test the file and see if it's an issue that we can reproduce.

qubit gravatar imagequbit ( 2013-03-07 22:31:41 +0100 )edit
0

answered 2013-03-10 09:13:34 +0100

ROSt52 gravatar image

The link as in @Huskey's test.odt file doesn't work. I just created a new TOC and all worked. @Huskey - How did you create the TOC? I assume currently that the problem/solution is there.

image description

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-07 10:14:06 +0100

Seen: 2,581 times

Last updated: Mar 10 '13