We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

How can I change the default style?

asked 2018-01-07 22:11:06 +0200

Dutch Jock gravatar image

I always change my style to 'courier new' and 12 points. But whatever I do writer will not accept the changes. Can you help me?

edit retag flag offensive close merge delete


There are few direct defaut styles. (In Writer for drawing objects e.g.)
By far the most of the "defaults" you get set opening a new document are taken from a template. As long as you did not create and use an own template, this is a built-in one.
However, you will want to create different kinds of documents...
Private letters to persons not willing to decipher your handwriting? . Letters to public authorities... (and surely some more).
More than one template needed.

Lupp gravatar imageLupp ( 2018-01-08 13:42:10 +0200 )edit

3 Answers

Sort by » oldest newest most voted

answered 2018-01-07 22:31:22 +0200

Lupp gravatar image

updated 2018-01-08 13:58:24 +0200

Your document surely accepts your changes, but...

To get new documents already regarding your preferred settings, apply the following procedure:

-1- Create a new document.
-2- Open the 'Styles and Formatting' dialogue (menu or F11).
-3- Modify the 'Default Style' paragraph style according to your preferences.
-4- Modify additional paragraph styles you intend to use.
... (depending on ...)
-5- Inspect additional style classes and make your changes if needed.
-6- Enter elements into the document that you want to be fix or prepared. (Own address e.g.)
-7- Save the document as a 'Writer' template (.ott).
-8- Go 'File' > 'Templates' > 'Manage Templates...'
-9- Search your just saved template using the 'Import' button and the dropdown list that opens.
-10- Complete the import of the template and make it your 'Standard' (rightclick, select).
-11- Close the dialogue.

If you now create a new 'Writer document', it will look like the template.

(Editing:) See also:

edit flag offensive delete link more


...but writer refuses to import the new template, what now?

Dutch Jock gravatar imageDutch Jock ( 2018-01-08 13:32:08 +0200 )edit

It doesn't.
Did you select the line containing a folder path from the dropdown, and then go to the template using the file picker? (You may have saved it to a different folder.)
Did you make sure you chose a Writer template (*.ott)?
What message did you get and interpret as a refusal?

Lupp gravatar imageLupp ( 2018-01-08 13:50:07 +0200 )edit

answered 2019-02-20 08:25:29 +0200

Tyco72 gravatar image

If you need to change only the default font and size there is a more quick way:

Open menu: Tools > Options > Libre Office Writer > Basic fonts

If in the management of templates you have not set any template as default, it should work.

edit flag offensive delete link more

answered 2018-01-08 13:23:28 +0200

Dutch Jock gravatar image

Thanks. Complicated, but I'll give it a go.

edit flag offensive delete link more


You may use the tool 'add a comment' to comment on answers.
Complicated? Hmmm. The management of a powerful tool will probably always require to accept some complications. As soon as you get used to templates, much of the stuff will appear rather simple and intuitive.
Good luck!

Lupp gravatar imageLupp ( 2018-01-08 13:31:19 +0200 )edit

Thanks, man! It worked! Is it OK if I check in when I come up against a new problem? I'm a new user and am used to Word, which I have used for decades.

Dutch Jock gravatar imageDutch Jock ( 2018-01-08 13:43:25 +0200 )edit

You are welcome, of course. In addition:
New question ==>> New topic
Immediately realated question ==>> Edit your OriginalQuestion (OQ) or comment on the answer you need additional info for.
You may accept an answer as correct by clicking "the hook". net to its top-left.
See also this (kind of a) tutorial.

Lupp gravatar imageLupp ( 2018-01-08 14:03:59 +0200 )edit
Login/Signup to Answer

Question Tools



Asked: 2018-01-07 22:11:06 +0200

Seen: 9,783 times

Last updated: Feb 20 '19