LibreOffice won't recognize Java [closed]

asked 2018-01-12 00:26:59 +0200

Jakal gravatar image

LibreOffice 5.4.4.2 (x64) will not recognize Java build 1.8.0_152-b16 (32-bit) on Windows 10 Pro system. I have uninstalled and reinstalled BOTH programs, wiped all other versions of Java from my machine (there were none anyway), and made sure I have the 32-bit Java installed.

I am trying to get an extension (oo2gd_3.0.1) to work but I cannot because it pops up the error message "Could not create Java implementation loader". No matter what I have done, going into the Tools>Options>Advanced and trying to add a JRE does nothing because no matter what folder (specific programsx86\java folder or entire c: drive) I select it gives me another error message "The folder you selected does not contain a Java runtime environment. Please select a different folder."

I have opened Java through my control panel to see the different JRE's and they are actually there. Control Panel>search for "java">click "Java (32-bit)" and then it takes me to Java Control Panel. I go to the Java tab and hit the View button to see the JRE I have. C:\Program Files (x86)\Java\jre1.8.0_152\bin\javaw.exe is the filepath on both user and system tabs.

Even when I put this exact filepath into LibreOffice - same error message of "The folder you selected does not contain a Java runtime environment. Please select a different folder." Please send help. I read somewhere that installing VC++ 2010 helps (no idea why) so I downloaded that and rebooted again - same exact problem. And yes, "use a java runtime environment" is checked under advanced in LibreOffice.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by m.a.riosv
close date 2018-01-12 01:05:25.593407

Comments

Hello,

LO 64-bit needs JRE 64-bit installed.

Ratslinger gravatar imageRatslinger ( 2018-01-12 00:32:28 +0200 )edit

Literally everywhere I looked said that even if the LO was 64, the JRE needed a 32. You're a scholar and a gentleperson and I love you. Thank you.

Jakal gravatar imageJakal ( 2018-01-12 00:42:03 +0200 )edit