Ask Your Question
0

F10 won't display the main menu but alt-F10 will??

asked 2018-01-19 00:33:56 +0200

garryjoz gravatar image

updated 2018-01-19 00:35:10 +0200

Using the F10 key as a shortcut should display the main menu but it does not, and the program will not allow F10 to be assigned to opening the main menu.

I have found that alt-F10 can be used instead, even though it is not documented as far as I can tell.

I suspect this is a Ubuntu problem but I don't care. I am just posting this here so maybe someone may be spared the trouble I just went through trying to get this frustrating monster to operate as it should.

If anyone can explain to me how to make the main menu display permanently I would be very grateful. There is no reason for it to be hidden, so I don't understand why it is designed this way.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-01-20 14:21:42 +0200

m.a.riosv gravatar image

May it's a matter on the computer configuration, some computer having special options on the Function keys, so with [Fn]+[Function key] works as function key.

On my Lenovo it is an option through 'Lenovo Campanion' not an OS option.

edit flag offensive delete link more
0

answered 2018-01-19 18:55:54 +0200

Ratslinger gravatar image

updated 2018-01-20 00:58:22 +0200

Hello,

Have tried to duplicate your problem on:

  • Ubuntu 17.10 Mate
  • Ubuntu 16.04 Unity, Mate, xfce
  • Mint 18.3 Cinnamon

using either Ubuntu LO or the LO from LibreOffice. (Have other Linux OS's but thought this was enough).

Cannot reproduce your problem. This in no way is stating you do not have this problem, just can't reproduce.

My tests show F10 selects the dropdown for menu item File if menu bar is present (more on this in a moment). Alt + F10 toggles an enlarged view (except in Ubuntu 16.04 Unity where it is tied to the system taskbar). Since starting with LO v4.3.x long ago, I have never seen a default installation without a menubar present.

Now there is the NEWER feature (EXPERIMENTAL) of the Notebookbar. This, when turned on does NOT typically display a menubar by default. Can't say based upon your question (can't see what you are looking at & no description provided) but this may be your problem.

Have some possibilities for you to try.

On a notebookbar with tabs, there is a tab with three horizontal lines. Left mouse click. There is an item Menubar with no check mark to its' left. Left mouse click it & menu bar will display.

If you are on a notebookbar & don't see the above tab, try this. Go to Options using Alt + F12. Under LibreOffice select Advanced. Select button (toward lower right) Open Expert Configuration. On that dialog, top line enter notebookbar & select Search button. Will see screen similar to:

image description

You will see lines (as I have one highlighted) with a property of HasMenubar. If the Value is False, double click the line & the value will change to True. Do this for each found item. Then OK on configuration & OK on Options dialogs. Menubar should be present.

If you situation is NOT related to the Notebookbar, then you may want to try resetting the user profile. For instructions on this, see this page.

The only other suggestion, if all else to no avail, uninstall LO, remove/re-name user profile, then reinstall LO.

If this answers your question please tick the ✔ (upper left area of answer). It helps others to know there was an accepted answer.

edit flag offensive delete link more

Comments

Thank you, I left-clicked the icon for setting ( a little cog I think) on the top right of the Ubuntu desktop. From from there, I selected the System Setting from the drop down menu, then the Appearance Icon in the Personal group, then select Always Displayed in the Menu Visibility option. This keeps the menu visible (after restarting LO), but I still need to use Alt-F10 to make the first (File) drop down menu appear. That will do me. I only have one lifetime. Thanks again.

garryjoz gravatar imagegarryjoz ( 2018-01-22 04:45:03 +0200 )edit

Might help to know which Ubuntu you are using. This all seems Ubuntu & not LO related. Also, Alt + F10 is enlarge window in LO. Are you saying F10 to select File from menu? Is so, that already worked for me in the testing under Ubuntu. May want to check your Ubuntu System Settings->Keyboard Shortcuts.

Ratslinger gravatar imageRatslinger ( 2018-01-22 04:57:15 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-19 00:33:56 +0200

Seen: 170 times

Last updated: Jan 20 '18