Ask Your Question

Why does setting webview as default remove some features?

asked 2018-01-23 15:10:28 +0100

Ooker gravatar image

updated 2018-01-25 12:51:30 +0100

After setting web view as default, the title changes to "LibreOffice Writer/Web", and some features such as comment is missing. Why is that? Here are what in the View menu:

Normal webview

Webview by default

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2018-01-24 02:08:55 +0100

Regina gravatar image

"Web View" for a normal text document and "Writer/Web" is not the same. If you have a normal text document and then click on "Web" in menu "View", it is still a normal text document and you can insert comments. The difference is, that you have no pages, but one large area. This "Web" view is the default setting for form-documents in Base.

This setting is a property of the document. If you like it as default, then take an empty document, set it into "Web" view mode and save it as template. Check "Set as default template" and all new documents will start in "Web" view.

"Web" view is sometimes useful, if you have content in a frame, that is larger as the frame and you want to see it. You do not see header and footer in "Web" view, but they still exists. Because there are no pages, footnotes area collected at the end of the document. Because there are no margins, content from the margin is shifted into the text area.

edit flag offensive delete link more



What's the difference between "Web View" and "Writer/Web"?

gtomorrow gravatar imagegtomorrow ( 2018-01-24 07:43:13 +0100 )edit

"Set as default template" applies only for creating new documents. How can I do this with existing ones?

Ooker gravatar imageOoker ( 2018-01-25 12:50:18 +0100 )edit

It is a document setting, not a setting of the UI. If you open a document, switch to Web View and save the document, then it will open in Web View next time. You might write a macro for switch to Web View and bind it to the "Open Document"-event.

Regina gravatar imageRegina ( 2018-01-25 15:11:48 +0100 )edit

I've made the macro, but it's weird that the document setting isn't saved as expected. "Load user-specific settings with the document" is already checked in the Settings.

Ooker gravatar imageOoker ( 2018-01-25 18:48:23 +0100 )edit

answered 2018-01-23 21:39:25 +0100

floris v gravatar image

updated 2018-01-24 12:48:11 +0100

Wrtier/Web is the inbuilt HTML editor of LibreOffice, with HTML as default file format. And because HTML doesn't support Comment boxes, when you edit or save a document (in HTML format), the comments would get lost, so they are disabled.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-01-23 15:10:28 +0100

Seen: 347 times

Last updated: Jan 25 '18