Ask Your Question

OpenPGP in LO6

asked 2018-02-01 20:07:09 +0100

bulldozer gravatar image


I just tried the new LibreOffice 6. It's great but I can't select an PGP-Key in the preferences. The dropdown is just empty but I have all the gpg-tools installed on my mac. Can anyone help how I can fix this? The help files dont contain anything about it yet.


edit retag flag offensive close merge delete


I have the same issue. LO6.0.21, GPG Suite 2018.1 both fresh installs running on MOS 10.13.3.

Under Libreoffice > Preferences > Libreoffice > User Data, OpenPGP signing key and OpenPGP encrypting key both state No key as the only option

Under Libreoffice > File > Digital signatures there are no certificates shown

GPG Suite 2018.1 works seamlessly with Apple Mail following install

So Like Bulldozer, how do I get LibreOffice to detect/see my GPG keys?

MykR gravatar imageMykR ( 2018-03-17 08:45:51 +0100 )edit

5 Answers

Sort by » oldest newest most voted

answered 2018-02-02 00:09:28 +0100

thb gravatar image

updated 2018-02-02 00:10:18 +0100

Hmm, so it works here out of the box with GPGTools - it seems gpgme has some hardcoded path names it checks, and then falls back to looking in $PATH.

What needs to be there is gpgconf, and perhaps also gpg/gpg2 binaries. Which gpg tools do you have installed, and where?

edit flag offensive delete link more


gpg (as link to gpg2), gpg2, gpgme. gpg as gpg should not be used for security reasons. All are in the $PATH variable.

bulldozer gravatar imagebulldozer ( 2018-02-02 07:04:59 +0100 )edit

I think gpgme initially looks for gpgconf, and calls that to obtain paths to everything else

thb gravatar imagethb ( 2018-02-02 16:08:00 +0100 )edit

Well, thats possible but LibreOffice seems not to work even with gpgme installed. The dropdown fields are still empty.

bulldozer gravatar imagebulldozer ( 2018-02-02 16:12:58 +0100 )edit

answered 2018-02-06 13:53:37 +0100

HI5 gravatar image

Same problem on my devices! Dell Latitude E6430 with Windows 10 Prof 64bit (16299.214) Lenovo ideapad MixII with Windows 10 64bit Home (16299.214)

Created fresh user account; reinstalled LO 6; reinstalled gpg4win gpg.conf = present ... \GnuPG\bin = in path

In LO 'Options/user data/encrytion' no keys are displayed In 'safe' dialogue' 'encrypt with gpgkey' the list of certificates is empty.

As it looks LO 6 just doesn't find the user gpg certificates!

As for the moment the "sign with openpgp" feature and "encrypt with openpgp" feature is competely useless

edit flag offensive delete link more

answered 2019-06-26 03:59:19 +0100

ntr4ef gravatar image

I am having the same issue on macOS Mojave with GPGTools installed. No key is the only option available when I open Libreoffice as an Admin user. However, when I execute Libreoffice from terminal as a super user I am able to access the keys... Any ideas?

edit flag offensive delete link more

answered 2018-12-20 00:55:01 +0100

cab404 gravatar image

updated 2018-12-20 00:56:00 +0100

So, I ended up basically writing my own decryptor.

works only for linux or through cygwin, I think.

That encryption is really a pain in the back. Seriously, that is one of the most stupid things I've ever seen in software. You are making "Encrypt with GPG" flag in one of the most visible places, without any "EXPERIMENTAL! THINK TWICE!!11", and do not provide ANY method of decryption. Meh.

edit flag offensive delete link more


This workaround helped me to decrypt the file on Linux, thanks. It's a shame that the LO feature does not work for decryption.

sboss gravatar imagesboss ( 2019-07-05 23:08:53 +0100 )edit

answered 2018-02-07 09:49:27 +0100

What type of file are you trying to sign? For me it works with odt documents on Debian, but not with docx files (presumably a limitation of this format?)

edit flag offensive delete link more


using odt, ods etc. Obviously problem with LO6 Windows version

HI5 gravatar imageHI5 ( 2018-02-07 16:25:22 +0100 )edit
Login/Signup to Answer

Question Tools



Asked: 2018-02-01 20:07:09 +0100

Seen: 4,967 times

Last updated: Jun 26 '19