Ask Your Question
0

New database creation problem

asked 2018-02-20 22:13:37 +0200

magharr gravatar image

updated 2018-02-24 12:07:56 +0200

Hi all, I am using LibreOffice 5.4.4.2 on Ubuntu 18.04 and having a weird problem. When I try to create a new database LibreOffice Base complains that the database is being used by another process and throws an exception that it cannot create and hence find the lock file because (I believe) it cannot write the lock file to the folder because of some permissions mixup. Here is the error message i got:

SQL Status: 08001 Error code: -1

The database is already in use by another process: lockFile: org.hsqldb.persist.LockFile@f63f959c[file =/home/magharr/Downloads/odb01-Employees.odb.lck, exists=false, locked=false, valid=false, ] method: openRAF reason: java.io.FileNotFoundException: /home/magharr/Downloads/odb01-Employees.odb.lck (Permission denied)

Now here is the part it gets weirder: When I download an .odb file and open it directly from firefox without saving (saving to firefox's tmp folder, wherever the heck it is) it works error free. No permission issues whatsoever.

Any ideas?

Best Regards.

edit retag flag offensive close merge delete

Comments

Hello,

From what is posted, 18.04 is still Alpha. Don't see any such problems in 17.10. You may want to report to Ubuntu as it would seem they would still be trying to correct problems in this release.

Ratslinger gravatar imageRatslinger ( 2018-02-20 23:45:30 +0200 )edit
Ratslinger gravatar imageRatslinger ( 2018-02-23 19:37:56 +0200 )edit

Thanks for the suggestions. I reported to Ubuntu as well. By the way LibreOffice 6 does not have this issue.

magharr gravatar imagemagharr ( 2018-02-24 12:09:00 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-23 18:41:14 +0200

updated 2018-02-28 22:02:11 +0200

Just yesterday I've got the same problem opening an old database I've been using since years. My Libreoffice is: Versione: 5.4.5.1 Build ID: 1:5.4.5-0ubuntu0.17.10.1 and I've opened it without problems a couple of weeks ago.

Solved by upgrading to version 6 via PPA libreoffice

sudo add-apt-repository ppa:libreoffice/ppa
edit flag offensive delete link more

Comments

@marcoemme This is not an answer to the posted question. Please use comment for this type of post.

Ratslinger gravatar imageRatslinger ( 2018-02-23 18:48:47 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-20 22:13:37 +0200

Seen: 206 times

Last updated: Feb 28 '18