Font rendering / kerning seems to be off (Calibri on Mac)

asked 2018-03-01 12:23:58 +0100

mkborregaard gravatar image

updated 2018-03-01 12:29:38 +0100

Fonts seem to render strangely, especially at small magnifications. Especially the letter spacing / kerning seems to be off, many of the letters actually appear to touch or be partially overlapping. Here's a comparison (MS Word on the left):

image description

(note e.g. "become" in line 3 how close 'e' and 'c' are, and how far 'o' and 'm' are). It looks slight on the example, but is enough to slow down reading for me quite significantly. It's not just the kerning, the font also renders "fuzzily".

I did work out that you could "Select All" then Format -> Character -> Position -> tick "Pair Kerning" from here, which seems to alleviate the issue slightly but not solve it. I couldn't see that that could be set as a default setting?

Is this due to something not being activated, should I install the fonts in a special way or something like that? I am on Mac, I found something that might solve it on Ubuntu here but that seems not to apply for the Mac.

Thanks!

edit retag flag offensive close merge delete

Comments

Thank you for raising this important issue! It's so frustrating that such an important tool in Linux is not getting such a basic thing right for so long. I'm confident it's a major turn-down for many people that attempt the transition from other OS... But we're not giving up!

datka gravatar imagedatka ( 2018-04-26 17:26:09 +0100 )edit