Ask Your Question
0

Conditional Formatting not working properly [closed]

asked 2013-03-21 01:51:53 +0100

Nozomi gravatar image

updated 2015-10-27 03:32:50 +0100

Alex Kemp gravatar image

In Libreoffice 3 until the latest on my laptop also found the same problem If I made a table that fullfill with alphabet, may be letter "A", 7 - 8 column and also 7 - 8 row and use a conditional formatting with 2 condition following

  1. If cell value equal to "A" so apply some style (may be red background)
  2. If cell value not equal to "A" so apply another style (may be green background)

The result should be displayed is red BG in all cell that have a letter "A" but I found only the 3rd column that working properly (displayed red BG) but for other appear green BG.

If I change the alphabet to number and applied the same condition it working properly. What shoud I do?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-27 03:33:04.158771

Comments

I don't know why you closed this question as outdated, it's still relevant for 5.4.3.2. Still had to google why it's not working without adding " quotes around values

int_ua gravatar imageint_ua ( 2017-12-18 17:07:39 +0100 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-03-21 03:44:47 +0100

Nozomi gravatar image

Dear horst

I just typed "A" and copied to other cells not typing all by my self. In fact, you can test it easily by your self but I also published some demonstration of the problem that I found. In the picture below, only column C, a third column, that working properly but for the same condition with number I found nothing.

Thank you for reply

image description

edit flag offensive delete link more

Comments

Can you upload this file?

JohnSUN gravatar imageJohnSUN ( 2013-03-21 08:52:32 +0100 )edit

Yes, sure. Please follow this link https://docs.google.com/file/d/0BxtQXMM0lbHJUU1wRGt5Szl1UXM/edit?usp=sharing but after I create the new one save it show different from this image but still not working properly.

Nozomi gravatar imageNozomi ( 2013-03-21 14:41:42 +0100 )edit

Yes, sure. Why not?

Nozomi gravatar imageNozomi ( 2013-03-21 14:41:44 +0100 )edit
0

answered 2013-03-21 23:13:07 +0100

horst gravatar image

Don't know what is wrong with your file. If I create a similar file from scratch, everything is fine.

Your file produces a wrong result even when I delete the Formating and start over then column C is always wrong. ????????????????????

Also the Cond.Format. Range for the 1. condition is the range of all "A"s, for the 2.condition it is range of all "1".

Try to start a new file and see if it persists.

edit flag offensive delete link more
0

answered 2013-03-21 15:42:05 +0100

JohnSUN gravatar image

OK. I just change 'A' in conditions to "A"... Work properly

Conditions Changes

edit flag offensive delete link more

Comments

I try to make the condition. First fill the range with A and 1, then create the condition. Weird that the 'A' works only in column C. I don't know why We must manually change/edit the condition from 'A' to "A" to make it work.

Paijo gravatar imagePaijo ( 2013-05-28 11:51:51 +0100 )edit

That was it!

fulopattila122 gravatar imagefulopattila122 ( 2014-03-11 11:59:53 +0100 )edit
0

answered 2013-03-21 02:41:03 +0100

horst gravatar image

Make sure that all "A"s are only A not blank+A or A+blank. Then the value is NOT "A".

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-21 01:51:53 +0100

Seen: 4,599 times

Last updated: Mar 21 '13