Ask Your Question
1

Change menu accelerator key

asked 2018-03-27 10:27:16 +0200

Evil Overlord gravatar image

updated 2018-04-06 12:04:47 +0200

Windows 10

LO 6.0.2.1

I somehow (probably by choice, but I don't recall how) added a Form item to my Writer menu bar. That's fine, though it turns out I don't use it much.

Unfortunately, the hot key (Alt+) for the Form menu is F - the same as for the File menu, which I use all the time. I know how to change hot keys for menu sub-items, but not for the menu itself.

How can I:

  • change the hot key for the Form menu to something other than F; or
  • remove the Form menu completely

Help much appreciated.

edit retag flag offensive close merge delete

Comments

Presumably you've been through all the Tools - Customise... options? Could you also edit into your question: (1) what operating system you're using, and (2) the LibO version in use? Thanks.

David gravatar imageDavid ( 2018-03-27 19:41:46 +0200 )edit

I have. Info added.

Evil Overlord gravatar imageEvil Overlord ( 2018-03-28 19:13:02 +0200 )edit

Seems odd that no one knows how to edit the top menu.

Evil Overlord gravatar imageEvil Overlord ( 2018-04-06 12:04:15 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-04-29 01:15:59 +0200

Evil Overlord gravatar image

Happily, the latest update to LO (6.03.2) fixed the problem by changing the accelerator key for the Form menu item.

edit flag offensive delete link more
1

answered 2018-04-06 17:20:07 +0200

Ratslinger gravatar image

updated 2018-04-14 00:48:42 +0200

Hello,

There doesn't seem to be a method to 'modify' the name of a menu bar item as you can for sub-items. Therefore you must first delete the item & create a new item.

To delete, go to the customize dialog. On right panel the is a dropdown which shows File. Select dropdown and look for your item & select it. Now that it is displayed you can delete it by clicking on the red X to the right. The menu item & sub-items are deleted once you click OK button on dialog.

When adding a 'New' menu item, the hot key is designated by inserting a tilde (~) prior (immediately left of) to the character you want for selection.

Edit 2018-04-13:

The above holds true if you are defining your own top level menu item.

The "fixed" menu items are generated based upon uno items. This (if not already) should be reported as a bug. However, if willing, you can make changes to the file containing the menu. The needed file is in the user config directory:

Windows
%APPDATA%\libreoffice\4\user   (LibreOffice 4, 5 & 6)
%APPDATA%\libreoffice\3\user   (LibreOffice 3)
Note: on a normal Windows install, %APPDATA% resolves to either "C:\Documents and Settings\<user name>\Application Data" (up through Windows XP) or "C:\Users\<user name>\AppData\Roaming" (Vista or later), at least on English versions of Windows (part of the path may be localized on non-English versions).

taken from ->LibreOffice user profile.

Under the 'user' sub-directory, you will find the file -> config/soffice.cfg/modules/swriter/menubar/menubar.xml

About 80% down in the file is the "Form" menu item:

 <menu:menu menu:id=".uno:FormatFormMenu">

Replace it with:

 <menu:menu menu:id="vnd.openoffice.org:CustomMenu1" menu:label="For~m">

For this setup, because of the placement of the tilde, Alt + m will select the "Form" menu item:

image description

Of course you can choose another letter wanted.

Be aware! If the menu is reset or the user profile regenerated, so is this change. It would need to be re-entered.

edit flag offensive delete link more

Comments

The problem is that Form is top-level menu item, equal to File. There doesn't seem to be any way to delete it. Selecting Form from that dropdown only allows deletion of sub-items, not of the Form menu itself. The result is that Alt+F goes straight to the Form menu, when I want it to go to File.

Evil Overlord gravatar imageEvil Overlord ( 2018-04-13 22:11:24 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-27 10:27:16 +0200

Seen: 106 times

Last updated: Apr 29 '18