Ask Your Question
0

Writer - cannot select shape object

asked 2018-04-02 22:02:48 +0200

AquaShark gravatar image

updated 2018-04-07 11:09:40 +0200

Hi,

there seems to be a bug in Writer 5.4.5.1 x64 Windows version which makes it impossible to select a shape (e.g. a circle) by clicking on it.

Here is how I can reproduce this behaviour:

  1. First you need two image files A and B. Both images shall be of similar size and cover more than 50% of the paper width when inserted in a writer document.

  2. Open Writer with a new, empty document.

  3. Insert image "A" into the document by the command Insert | Image. Set its anchor mode to "as character" (= right click the image, Anchor | As character)

    1. Insert a circle (command Insert | Shape | Basic | Circle) and place it inside image A so that it looks similar to that screen shot (yellow = image A; blue = circle shape): image description
  4. Place the cursor before the image (left click left to the image and press Ctrl + Pos1 so the cursor bar shows up left to the image).

  5. Insert image "B" into the document by the command Insert | Image. Set its anchor mode to "as character" (= right click the image, Anchor | As character). It then looks like that (green = image B): image description

  6. The circle now appears inside image B. Try to click the circle - it cannot be selected.

Can you reproduce this behaviour? Any idea on how to solve it? Is it a bug and if yes, how is the procedure to report it?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-04-03 10:33:35 +0200

updated 2018-04-07 11:35:16 +0200

I reproduce with current master on Win10. I could fix this by first selecting the shape using @pierre-yves samyn advise, and then sending it to background and back to foreground.

Another way to select an object is to use Drawing toolbar (Show Draw Functions on Standard toolbar). There, use Select (first button with an arrow), and start selecting so that enclose only required object (not the image) - start from the right margin.

This looks like a bug. Please see How to use this Ask site (available from this site's front page) for the bug reporting hints.

edit flag offensive delete link more
0

answered 2018-04-03 10:05:00 +0200

pierre-yves samyn gravatar image

Hi

I do not reproduce (despite the precision of the given steps, reproducing the context is not obvious).

Anyway, you should be able to select the image you want by double clicking on its name in the navigator (sidebar)

Regards

edit flag offensive delete link more
0

answered 2018-04-07 11:19:23 +0200

AquaShark gravatar image

updated 2018-04-07 11:19:58 +0200

Hi @Mike Kaganski & @pierre-yves samyn!

Thank you for your answers.

@pierre-yves samyn: I revised the description. I hope it is clear now.

@both: Selecting the shape using the navigator works with newly added shapes. However, none of the already existing shapes in my existing Writer documents show up in the navigator pane:

image description

See the example document attached.

Example document with shapes not showing up in the navigator

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-02 22:02:48 +0200

Seen: 840 times

Last updated: Apr 07 '18