Ask Your Question
2

LO writer on Linux: change appearance of typing cursor (i.e. not mouse cursor) [closed]

asked 2018-04-24 19:59:26 +0100

carnish gravatar image

updated 2020-07-25 17:44:56 +0100

Alex Kemp gravatar image

up vote 0

When editing a text in LO writer I will often lose the typing cursor and have to enter text or move the direction keys to create movement on the page so that I can find the cursor. Is there a way of enlarging the typing cursor or making it more obvious?

The LO forum has fixes for Windows, but I haven't found one for Linux.

Note that I am not talking about the mouse cursor here. I can easily modify the size and color of the mouse cursor, and make it ripple with the control key, but this is not about the mouse cursor. This is the tiny little cursor that marks the editing position in the document. (Update - which I have learned is called the 'caret'.)

Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-25 17:45:13.358234

Comments

Jim K gravatar imageJim K ( 2018-04-24 23:50:46 +0100 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2018-06-21 13:47:21 +0100

MarkieMark gravatar image

updated 2018-06-22 16:49:55 +0100

In newer gtk3 configurations with compiled gtk themes, you just need to add this to ~/.config/gtk-3.0/gtk.css, create the file as necessary

* { -GtkWidget-cursor-aspect-ratio: 0.2; }
edit flag offensive delete link more

Comments

Any idea how to change the color?

carnish gravatar imagecarnish ( 2018-08-22 00:00:50 +0100 )edit

According to gnome developers, we should use caret-color as a CSS property. However, I haven't figured it out how. There are no working samples anywhere. Check: https://developer.gnome.org/gtk3/unst...

Eduardo Villegas gravatar imageEduardo Villegas ( 2020-07-23 21:06:23 +0100 )edit
1

answered 2018-05-30 05:00:41 +0100

WhatHaveYou7 gravatar image

I have the same problem. The solution on the page linked by @carnish seems no longer to work - as indeed a comment on that page says.

Libre Office Writer 6.0.4.2 Linux Mint 18.2

edit flag offensive delete link more
0

answered 2018-12-12 13:25:59 +0100

Using LibreOffice 6 on Ubuntu 16.04. I tried the gtk 3.0 modification to change text cursor thickness, and it worked beautifully for nearly all editing functions in most programs - gedit, Thunderbird, URL editing in Firefox and Chrome etc etc. But not for LibreOffice, unfortunately -- the cursor continues to be almost invisible in insert mode. LO does not get the cursor config from the system-wide settings in Linux. Any solution?

edit flag offensive delete link more

Comments

This sounds like a bug: LO should take it from system. Please file it accordingly.

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-12 13:28:31 +0100 )edit
0

answered 2018-05-04 14:22:25 +0100

carnish gravatar image

There is an excellent answer from DK Bose here:

https://askubuntu.com/questions/10278...

edit flag offensive delete link more

Comments

This question on the askubuntu site has been updated to include the suggestion put here by MarkieMark.

carnish gravatar imagecarnish ( 2018-08-21 15:11:10 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-04-24 19:59:26 +0100

Seen: 1,918 times

Last updated: Dec 12 '18