LO writer on Linux: change appearance of typing cursor (i.e. not mouse cursor)

up vote

When editing a text in LO writer I will often lose the typing cursor and have to enter text or move the direction keys to create movement on the page so that I can find the cursor. Is there a way of enlarging the typing cursor or making it more obvious?

The LO forum has fixes for Windows, but I haven’t found one for Linux.

Note that I am not talking about the mouse cursor here. I can easily modify the size and color of the mouse cursor, and make it ripple with the control key, but this is not about the mouse cursor. This is the tiny little cursor that marks the editing position in the document. (Update - which I have learned is called the ‘caret’.)


Also posted at Libreoffice writer: typing cursor appearance (not mouse pointer) - Ask Ubuntu.

In newer gtk3 configurations with compiled gtk themes, you just need to add this to ~/.config/gtk-3.0/gtk.css, create the file as necessary

* { -GtkWidget-cursor-aspect-ratio: 0.2; }

Any idea how to change the color?

According to gnome developers, we should use caret-color as a CSS property. However, I haven’t figured it out how. There are no working samples anywhere. Check: https://developer.gnome.org/gtk3/unstable/GtkWidget.html#GtkWidget--s-cursor-color

I have the same problem. The solution on the page linked by @carnish seems no longer to work - as indeed a comment on that page says.

Libre Office Writer
Linux Mint 18.2

There is an excellent answer from DK Bose here:

This question on the askubuntu site has been updated to include the suggestion put here by MarkieMark.

Using LibreOffice 6 on Ubuntu 16.04.
I tried the gtk 3.0 modification to change text cursor thickness, and it worked beautifully for nearly all editing functions in most programs - gedit, Thunderbird, URL editing in Firefox and Chrome etc etc. But not for LibreOffice, unfortunately – the cursor continues to be almost invisible in insert mode. LO does not get the cursor config from the system-wide settings in Linux. Any solution?

This sounds like a bug: LO should take it from system. Please file it accordingly.