Ask Your Question
0

how to sum a column

asked 2018-05-21 20:00:48 +0200

BigMamaH gravatar image

I know I can find the sum of a column by entering "=D1+D2+d3..." but there's got to be a shorter way and I don't remember it. Please help.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-02-10 20:34:34 +0200

MykeC gravatar image

I needed values in Column F to display a "running total" of all values from a fixed upper cell in E (i.e. the start date) down to the current row which represents the current date (i.e. a new row of data is added each day).

At first I thought this was a simple matter of summing all values in E... for which Grantier's answer works well. However, in keeping with the spirit of maintaining a running total, I realized what I really needed was a sum of the current day's value in E with the previous day's value from one row higher in F.

For that I used "=SUM(F4+E5)" in the F5 cell and then used the "fill handle" in the bottom right corner of F5 to drag that formula down column F as far as needed.

Either way seems to work. I think the second method is more appropriate for my task at hand. Thanks for helping me with this! Most of my spreadsheet work was done over 20 years ago in the mid-1990s so I'm a bit rusty. Fortunately, it comes back to me quickly when I try to remember it. Amazing how so little has changed in all this time!

edit flag offensive delete link more
0

answered 2018-05-21 20:12:06 +0200

Grantler gravatar image

Try this:

=SUM(D1:D3)
edit flag offensive delete link more

Comments

Sorry, I tried this before i submitted the question. It does not add the column.

BigMamaH gravatar imageBigMamaH ( 2018-05-22 14:11:44 +0200 )edit

If it doesn't then the cell content may be text instead of numbers, see this FAQ.

erAck gravatar imageerAck ( 2018-05-22 14:30:41 +0200 )edit

The column was Currency. I changed it to Number, removed the currency symbol, aligned the figures, and then copied to a new page. The numbers do not add, I simply get the first number in the column. Grantier's example has a space after SUM and before the ( and another space before the : and I tried the formula with this spacing and with no spacing. It still does not add.

BigMamaH gravatar imageBigMamaH ( 2018-06-06 08:45:27 +0200 )edit
1

There is no space between SUM and ( above.. anyway, spaces are cosmetic and don't affect the formula.

Your numbers still not adding indicates the cell content really is of type Text instead Numeric. Please follow the procedure given in the FAQ above. Just changing the number display format and aligning content does not re-enter values. The values have to be re-entered after the number format was changed to something different than Text. Copying cells does not change anything.

erAck gravatar imageerAck ( 2018-06-06 09:56:53 +0200 )edit
0

answered 2019-01-25 22:23:05 +0200

I don't know if anyone figured this out yet, or if anyone else has had this problem, but I did. The way I fixed it was to copy the block of numbers, and then 'paste special' back into the same block of numbers. Not sure what happened, I tried to reformat the column, then the specific cells, to number, but LibreCalc still refused to sum the numbers. Anyway, 'paste special' did the trick.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-21 20:00:48 +0200

Seen: 15,751 times

Last updated: Feb 10