Ask Your Question
0

Fix uneven header spacing

asked 2018-06-01 18:44:43 +0200

phunanon gravatar image

updated 2018-06-01 21:36:00 +0200

Hello,
How do I make both left and right pages have the same spacing between the header?
Below illustrates, in Book view, the uneven header spacing I just can't fix.

image description

(before edit)

Thank you for your time!

Edit: result of manual setting of height to .9cm:

image description

I preferably want to set both sides to 0cm.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-06-01 20:44:18 +0200

ajlittoz gravatar image

updated 2018-12-31 09:50:22 +0200

By default, header area is auto-adaptative, meaning its height is dynamically computed to fit content. Consequently, if left and right headers have different heights due to their specific content, you get the behaviour you complain about.

However, it is not completely obvious in the screenshot whether "Phology & Orthography" and "Writing Puctuation" are part of the header or text. The page numbers are in the header but what about the other elements? (please edit your question for additional info, do not use an answer for that).

The solution lies in parametering the page styles. I assume you know what pages styles are and how to access them since you seem to use different left and right styles.

  • First make sure that margins defined in Page tab are the same for both page styles.

  • Then in Header tab, uncheck AutoFit height and define a fixed height in the Height entry box. Compute the minimal needed value in the largest header from the properties of paragraph style used in the header (usually sum of font size and spacings above and below; if multiple lines, add leading). The Spacing box defines the white space between header and text.

That's for the basics. Text area should begin at the same vertical position in both pages.

If you want to align header lines, mostly if you have single-line header on one side and multi-line header on the other, use different paragraph styles for each page, e.g. Header Left and Header Right so that you tune properties independently. In this case, play with spacings Above paragraph and Below paragraph in Indent & spacing tab, eventually with Line spacing.

EDIT 2018-12-31

From the comments, there seems to be difficulty achieving the desired results. Remember two controls are involved: settings for the header paragraph style and those for the "geometry" in the page style.

Header paragraph style: from my experiments, only spacing Above paragraph will be honoured. Below paragraph results in no spacing at all, whatever the setting in the dialog.

Page style: Height, if AutoFit unchecked, will override paragraph style Above+font size and leading+Below (eventually clipping the line if too small). The gap between header and main text area is controlled by Spacing and it can be set to zero if you want your header really adjacent to text.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Thanks for your time with this! I apologise for the not-so-helpful screenshot, but setting the height manually to .9cm has resulted in a partial success! What I'd preferably like to do is set both heights to 0cm. The effect .9cm has on the document is edited in as a second screenshot, if you could look over it?

phunanon gravatar imagephunanon ( 2018-06-01 21:37:36 +0200 )edit

From the new screenshots, you have a problem with the paragraph styles in your headers. They are manifestly different which is the cause of your problem. With the cursor in each header, check the para style names. If they are different (which is perfectly acceptable e.g. to left/right flush on left/right page), give same spacing properties. If they are the same, direct formatting is playing tricks on you. Select whole headers in turn and Ctrl+M to clear. This should help.

ajlittoz gravatar imageajlittoz ( 2018-06-01 21:59:47 +0200 )edit

I am having the same kind of problem. Thank you for your suggestions, but the header only uses one paragraph style and the only direct formatting is right-alignment of the right pages, but the headers are still not even for me.

lomacar gravatar imagelomacar ( 2018-12-31 03:27:30 +0200 )edit

Strangely, at least in my case, the header Spacing and Height settings have no effect on the left page. And yes, the pages are using the same page style.

lomacar gravatar imagelomacar ( 2018-12-31 03:48:56 +0200 )edit

@lomacar: please attach a stripped down version of your file in an answer (you cant' attach files to a comment; I'll delete the answer afterwards) so that I can have a look

ajlittoz gravatar imageajlittoz ( 2018-12-31 09:54:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-01 18:44:43 +0200

Seen: 171 times

Last updated: Dec 31 '18