Ask Your Question
0

Can't change default language permanently [closed]

asked 2018-06-04 15:02:38 +0100

Xbaer gravatar image

Hi. I'm using LibO 6.0.4.2 on Win and am desperately trying to permanently change the 'default language for western documents', 'CTL' and the page format (Letter -> A4). I have tried doing so in Tools | Options > Language and the language-submenu. When I open a new LibO-Document, I find the previous defaults and not the ones I implemented. Can I maybe change a program file to make my desired defaults stick? If the problem is rooted in Windows: Where do I change the language there? Kind regards!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Xbaer
close date 2018-06-05 23:13:05.851949

2 Answers

Sort by » oldest newest most voted
1

answered 2018-06-04 21:28:26 +0100

RGB-es gravatar image

On an empty document, open the style editor (F11) and modify both, the Default paragraph style and the Default page style. On the Font tab of the paragraph style you can set the language. Now, the last step: File → Template → Save as template, give the template a name and check the "set as default template" option before accepting.

edit flag offensive delete link more
0

answered 2018-06-04 22:59:51 +0100

Xbaer gravatar image

Did that. Then I created a new odt-File in Windows, opened it - lo and behold: it is designed with the old defaults, not the new template. If I create a new odt-File with LibreOffice, the new template is in action, though. (Thanks so far!) Can you give me a hint how to teach windows to use that template as well when creating a new file?

edit flag offensive delete link more

Comments

The OS is using a different template, so you need to locate where that "system template" is stored and overwrite it. I have no experience on windows so I cannot tell you where you need to look, sorry.

RGB-es gravatar imageRGB-es ( 2018-06-04 23:23:43 +0100 )edit

Ok, that was helpful! -> C:\Program Files\LibreOffice\share\template\shellnew ... that's where windows goes to find the templates for the context menu. Amazingly, it is enough if there is a .odt-file with the correct settings instead of a template. (soffice.odt) My problem is solved. :-)

Xbaer gravatar imageXbaer ( 2018-06-05 23:12:23 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-06-04 15:02:38 +0100

Seen: 156 times

Last updated: Jun 04 '18