Can’t change default language permanently

Using version under Manjaro Linux. Originally installed in Australia, now in UK. Everything else on the PC is now pointing to the UK.
I can change the default in tools/option/languages/Default Language for Documents but on restart it reverts to Australia. A past question - Can't change default language permanently - had an answer for Windows that apparently worked, but the question is closed.
I saw another answer that said the default for a new document is not derived from a template, so fiddling with templates won’t work - I’ve tried that extensively.
Any ideas?

Are you using some default template? In this default template, have you configured Default Paragraph Style for en_AU instead of relying on settings of Tools>Options?

Open your template for editing and make sure that it is set as the default template.
Set its language together with check box “Current document only”.
Save the template.

Before today I had not looked at tools/Language/For Selection etc. After setting the default language to UK in Tools/options I opened tools/language and saw initially an AU option for Selection etc as well as UK and US, but the AU box vanishes if one of the others is ticked. Only “For Selection” can be set, ticking the boxes for the others does not have any effect. I have clicked on "reset to default language for Para and All Text, and restarted. I now find that a new document is set to language UK. Somehow what I did fixed the problem, so thanks for pointing me in that direction.

I have tried that before, but until following ajlittoz’s clue the setting had always reverted on restarting.
Still a mystery, but anyway it now works as it should.

Please mark the answer / comment that solved your problem as “Solution” (It’s next to the bookmark symbol). Thanks.

1 Like