Ask Your Question
1

Set memory settings in Version: 6.0.4.2

asked 2018-06-12 19:09:09 +0100

Barney_G gravatar image

I'm using Version: 6.0.4.2 and I'm dealing with a large spreadsheet 90,000 + rows

Calc hangs. I read that in previous versions, one could increase the memory for such situations but that option seems to be missing in the most recent version.

Am I missing something?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-06-12 19:21:28 +0100

kompilainenn gravatar image

https://wiki.documentfoundation.org/R...

read comment from Mike in bug

edit flag offensive delete link more

Comments

2

Specifically, in Options->LibreOffice->Advanced, click Open Expert Configuration; in the dialog, navigate to org.openoffice.Office.Common/Cache. The subelements and values there correspond to the old "Memory" settings page. And unless your spreadsheet uses large number of images/OLE objects, these settings are useless for your case - as for most other cases where people believe that the settings would improve things; which is the reason to remove them to reduce misconception.

Mike Kaganski gravatar imageMike Kaganski ( 2018-06-13 04:18:16 +0100 )edit

This worked well and solved the problems I was having with calc and write constantly not responding, also crashing and having to recover the files, all very time consuming.

GeorgeCurtis gravatar imageGeorgeCurtis ( 2018-07-13 23:14:52 +0100 )edit

Hi Mike: Can you let me to know what value is better in TotalCacheSize, ObjectCacheSize, ObjectReleaseTime, GraphicMemoryLimit? thanks

joey.liao gravatar imagejoey.liao ( 2018-10-02 10:35:47 +0100 )edit

@joey.liao: if there were some "better values" (globally), we would definitely set them as the default; and current default values are what we suppose generally suitable in vast majority of cases.

You should experiment with the settings to decide if changing them improves things for your use case.

Mike Kaganski gravatar imageMike Kaganski ( 2018-10-02 10:51:02 +0100 )edit

Can anyone tell me what values are acceptable and in what subelement to change the values so that I can improve the RAM for my use of Writer? Writer has been crashing on me and unexpectedly freezing up. I suspect this might have something to do with it. I'm using Windows 7, 64 bit. 6.1.3

Access.Journal gravatar imageAccess.Journal ( 2018-11-22 04:30:45 +0100 )edit

These options were "hidden", and are expert configuration for a reason. There's no "acceptable" values, only trial and error may help you.

Or may not: the settings control very specific area in memory management. In most aspects, LibreOffice doesn't need any adjustments to just consume all available memory.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-22 07:43:39 +0100 )edit
0

answered 2019-01-09 21:15:29 +0100

zman58 gravatar image

I found that bumping up the older "Memory" settings, resolved a very consistent crash which occurs when I edit some drawings--which are not very large.

Once I make these changes, I no longer see the crash issue and LibreOffice seems to run faster. It remains perfectly stable for me now.

The settings I use currently under Options - LibreOffice - Memory are:

Use for LibreOffice: 200 MB Memory per object: 10.0 MB

These Memory settings, above correlate exactly to the following Advanced attributes in byte count values below:

Options - LibreOffice - Advanced - Expert Configuration - org.openoffice.Office.Common - Cache - Graphic Manager TotalCacheSize 209715200 (bytes) (same as 200MB above) ObjectCacheSize 10485760 (bytes) (same as 10.0MB above)

I do not believe these particular values are specifically optimal, only that they are significantly higher than the default values provided before making the changes. Adjust them as needed for your own needs, I wanted to show the relationship between the old "Memory" and now "Advanced" settings.

Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial4 CPU Threads: 8; OS Version: Linux 4.13; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

edit flag offensive delete link more

Comments

Use for LibreOffice: 200 MB Memory per object: 10.0 MB

they are significantly higher than the default values provided before making the changes

The default values in current versions are 190 MB and 12 MB per object, resp. If you saw different values, than it's a sign of previous "tweaks", that is something not recommended, and that was the real cause of your crashes. Removal of the page was partially driven by these "tweaks" that mostly break things, for no good reason (but being a cargo cult).

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-09 21:24:23 +0100 )edit

Thanks Mike, That looks promising. I have been using Linux Mint Cinnamon Desktop for years. The LO Memory defaults provided on that distribution are only 20MB and 5.2MB respectively. Someone up the chain needs to make an adjustment. I have not checked the very latest Linux Mint 19.1 for specifics, but earlier 17 18 and 19.0 series releases all had the very low default values.

zman58 gravatar imagezman58 ( 2019-01-09 21:41:03 +0100 )edit

Ehh, given that the dialog was removed from 6.0 (where the defaults are as I said), I overlooked

Version: 5.1.6.2

Of course, the 5.1 that originated in 2015 had those small defaults.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-09 22:13:50 +0100 )edit

Just confirmed with my son; The very latest Linux Mint Cinnamon 19.1, recently released, is now using LO version 6.x with much higher defaults.

TotalCacheSize: 400000000 ObjectCacheSize: 12600000 ObjectReleaseTime: 600 (10 min)

This means that Linux Mint v19.1 latest version will not be experiencing frustration with LO crashing because of this problem. Probably the same for the latest Ubuntu desktop since Linux Mint is based on that. Good news for sure.

zman58 gravatar imagezman58 ( 2019-01-11 16:54:35 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-06-12 19:09:09 +0100

Seen: 4,017 times

Last updated: Jan 09