Ask Your Question
0

soft line break with forward slash?

asked 2018-06-22 00:06:49 +0200

mrodent gravatar image

At the moment, in LO Writer, if I write "Monthly/occasional disk images" in a table cell and then I make the column progressively thinner eventually a line break will happen (a "soft" line break).

But at the moment it goes like this:

Monthly/occasion
al disk images

whereas I would like it to break like this:

Monthly/
occasional disk images

or more likely this:

Monthly/
occasional
disk images

It appears that LO Writer is considering a forward slash as an "inviolable character" for the purposes of rules for inserting soft line breaks. Is there any way to tell it that this is not an "inviolable character"?

edit retag flag offensive close merge delete

Comments

LibreOffice of which version? It's possible that some very old version didn't follow the rule to break at the forward slash, the rule that Unicode had introduced to allow breaking the long URLs.

Mike Kaganski gravatar imageMike Kaganski ( 2018-06-22 09:50:05 +0200 )edit

I confirm the described behavior with LO 6.0.4/Windows 7 using Liberation Serif. But with Linux Biolinum G and many other fonts, it is fine. So, it looks like a problem specific to fonts. Anyway, see my answer.

gabix gravatar imagegabix ( 2018-06-22 13:38:30 +0200 )edit

I tested with 6.0.5.2 on Win10 - and can't reproduce with Liberation Serif...

Mike Kaganski gravatar imageMike Kaganski ( 2018-06-22 13:46:42 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2018-06-22 00:16:28 +0200

floris v gravatar image

I can't reproduce that - Libre breaks at exactly the points where you want it. But there's probably something else going on here. If Libre breaks a line in the middle of a word, you probably inserted non-breaking spaces instead of ordinary ones. If you turn on field shadings (Ctrl+F8), non-breaking spaces appear as thin, gray rectangles.

Maybe the locale also plays a role.

edit flag offensive delete link more
0

answered 2018-06-22 09:37:09 +0200

gabix gravatar image

updated 2018-06-22 09:38:34 +0200

I would insert a zero-width space after the slash. To input, type 200b and press Alt+X.

edit flag offensive delete link more
0

answered 2018-06-25 19:19:33 +0200

Henk C. Meerhof gravatar image

All my clever fellow LO-users forgot that it could also be that the style of the Table or the style used for your table forbids hyphenation ... so check the style.

edit flag offensive delete link more

Comments

Hyphenation isn't an issue here, you may mean word wrap, which seems to be disabled here, but as far as I know you can't disable that, except by using non-breaking spaces.

floris v gravatar imagefloris v ( 2018-06-25 19:50:50 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-22 00:06:49 +0200

Seen: 115 times

Last updated: Jun 25 '18