Ask Your Question
0

unable to apply new page style

asked 2018-07-03 16:56:54 +0200

frepie gravatar image

updated 2018-07-03 19:49:37 +0200

Hi, I am trying to create a document (letter followed by resume) where

  • the first page is a letter (no header/no page number)
  • the second page would be the first resume page (first page header and page number)
  • the following pages would be "default" (simpler header than first resume page and page number)

Now I tried to create a custom page style for the first page (named letter) for my first page but Writer to applies it throughout the whole document. I then scroll down to the second document page (the first resume page) and try to apply another style (that I named cv_first_page) but then that style (first_cv_page) is applied to my first page on which I had previously the "letter" style. EDIT: I added my document C:\fakepath\Frederick Pierre ing mec lettre et cv 2018.odt

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2018-07-03 17:38:10 +0200

ajlittoz gravatar image

To be able to apply various page styles, you must insert a page break so that you can change the page properties. Without page breaks, the same page style is applied continuously.

Without going through the complex mechanism of styles interaction, you can do that manually.

  • Set the cursor where you want the page break to happen
  • Insert>Manual Break (not Insert>Page Break or Cntrl+Return)
  • In the dialog which pops up, choose the page style with which the page will begin, and also reset page number to 1

You're done.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Without page breaks, the same page style is applied continuously.

No, not necessarily. You can change it via the Organizer tab in the style properties dialog.

gabix gravatar imagegabix ( 2018-07-03 18:02:46 +0200 )edit

@gabix: yes, but OP is obviously a newbie and that's part of style subtleties ;-)

ajlittoz gravatar imageajlittoz ( 2018-07-03 19:26:47 +0200 )edit

I tried through the organizer but it doesn't work. I double clicked several time on the desired style but changes are carried out throughout the document.

frepie gravatar imagefrepie ( 2018-07-03 19:34:36 +0200 )edit

The Link drop-down menu in the Organizer tab is used for automatic style switch when a page overflows. For the time being, try to make it work with the manual procedure. Then, download the Writer Guidefrom https://documentation.libreoffice.org... and read it to have an overview of the possibilities.

ajlittoz gravatar imageajlittoz ( 2018-07-03 19:41:51 +0200 )edit

How do you proceed when you want to add a page on top of an existing document? Where would you apply the manual break? It automatically adds a blank page that is not required. Deleting in removes the manual break

frepie gravatar imagefrepie ( 2018-07-03 20:08:16 +0200 )edit

You nearly made it. Right-click on 1st para in your CV, Paragraph. Go to Text Flow tab. You already have Page break before. Make sure style is cv premiere page and tick Page Number so that you can reset it to 1. Your 1st page is already Lettre.

In Organizer for cv premiere page, set Next style to Default Style. The structure of your doc is done.

Now tune your page styles to your liking.

ajlittoz gravatar imageajlittoz ( 2018-07-03 20:34:25 +0200 )edit

If the letter part will never flow to page 2, you also apply the First page page style, then modify Default page style according to your needs: enable header and anything else.

floris v gravatar imagefloris v ( 2018-07-03 22:58:43 +0200 )edit

Ok thank you, I manage to have the correct styles for each pages. But now the numbering is all off. I do have "1" as the page number for my first resume page, but the second page also has "1" as its page number. I also put the number of pages so my page numbering looks like "1 of 3" ("page number of total number of pages") but the total number of pages is now 6! when it should be 3. I know I could manually edit these values but that is not how it should be done.

frepie gravatar imagefrepie ( 2018-07-04 22:33:43 +0200 )edit

Share the problem file.

gabix gravatar imagegabix ( 2018-07-05 06:10:00 +0200 )edit

Remember that total page count refers to the whole document, not to a part of it covered by a single page style. If your doc has 6 pages, out of it 3 pertain to resume, you can't have "1 of 3" in your resume but you get "1 of 6".

ajlittoz gravatar imageajlittoz ( 2018-07-05 06:56:25 +0200 )edit
0

answered 2018-07-03 18:04:31 +0200

gabix gravatar image

Read this tutorial. In particular, this section, pay attention to the paragraph 3, which should be the answer to your situation.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-03 16:56:54 +0200

Seen: 291 times

Last updated: Jul 03 '18