Ask Your Question
0

Lo Basic line number bug?

asked 2018-08-08 16:26:56 +0100

BillC gravatar image

A macro over 1000 lines causes scroll glitch. (at least for me)

Test procedure:

  1. Start LO and open the BASIC editor (e.g. via macro editing from within a Calc spreadsheet)
  2. Under the View menu, activate the line number display
  3. Open (or create) a long (Over 1100 lines of code) BASIC macro file in the BASIC editor
  4. Click on line 1
  5. Scroll down past line 999 Once you get to line 998 it starts back at line 1
  6. Click on line 500
  7. Scroll down past line 999 Once you get to line 998, it starts back at line 500

Version: 6.0.5.2 Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16 CPU threads: 8; OS: Linux 3.19; UI render: default; VCL: gtk2; Locale: en-US (en_US.UTF-8); Calc: group

Is there a fix other than turning off line numbers or making shorter macros? How do I report this if it is a bug?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-08 16:47:20 +0100

Ratslinger gravatar image

updated 2018-08-08 16:49:57 +0100

Hello,

If you use the arrow down or page down or scroll bar it works correctly. Only the mouse wheel acts this way. See also this post -> How can I get the line number column in the Basic IDE to work?

For bugs use Bugzilla to check if reported already and if not report there -> Bugzilla

edit flag offensive delete link more

Comments

Thanks, found existing bug report, left comment, so maybe someone will fix it.

BillC gravatar imageBillC ( 2018-08-08 20:34:59 +0100 )edit

Just a note - existing report is -> Bug #116743

Ratslinger gravatar imageRatslinger ( 2018-08-09 06:22:27 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-08-08 16:26:56 +0100

Seen: 40 times

Last updated: Aug 08 '18