Ask Your Question
0

disable auto full screen for embedded videos [closed]

asked 2018-09-04 12:10:03 +0200

Goran gravatar image

updated 2018-09-05 15:21:54 +0200

ebot gravatar image

How can I disable the automatic full screen mode of embedded videos in Impress? I would like the video to be played in the slide show where it was inserted, and in the size chosen by the user when inserted.

I recently upgraded libreoffice from 5.1.6.2 to 6.0.3.2, where in version 5, this was no problem.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ebot
close date 2018-09-06 09:50:49.554504

Comments

Select in the menu Slide Show>Presentation Settings in Presentation Mode. Is that what you are looking for?

ebot gravatar imageebot ( 2018-09-04 12:25:57 +0200 )edit

I'm afraid not. Presentation mode under slide show settings, let's one choose between "full screen" and "In a window". This does not change how videos are displayed.

Goran gravatar imageGoran ( 2018-09-05 09:11:55 +0200 )edit

Which dimensions does your video have in edit mode? Which OS do you use?

ebot gravatar imageebot ( 2018-09-05 09:30:42 +0200 )edit

Just like an image, I would like to adjust the size of my video inside the slide. I do not understand what you mean with "dimensions" in this setting. I'm running linux (ubuntu 18.04).

Goran gravatar imageGoran ( 2018-09-05 14:13:08 +0200 )edit

if using linux (eg ubuntu 18.04), you can remove libreoffice-gtk3 and install libreoffice-gtk2. more: https://www.reddit.com/r/libreoffice/...

update: it might be missing package with gtk3, solving by installing apt install gstreamer1.0-gtk3

gsedej gravatar imagegsedej ( 2019-03-14 09:08:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-09-05 14:48:34 +0200

ebot gravatar image

When I insert a video with me, it is displayed very large (33,87 x 19,05 cm):

image description

The display size can be reduced in the sidebar, e.g. 10 x 5,62 cm:

image description

Look for a check mark "Keep aspect ratio".

image description

edit flag offensive delete link more

Comments

Yes, I know. However, my problem is that the inserted video, no matter how it's position has been modified and the "keep aspect ratio" option is on, the video is automatically displayed in full screen when I'm presenting the slide show. The video is therefore on top of other things that I might have in the slide.

Goran gravatar imageGoran ( 2018-09-05 14:55:08 +0200 )edit

Choosing to "protect" position and size does not work either

Goran gravatar imageGoran ( 2018-09-05 15:02:21 +0200 )edit

Here are some answers to the same problem: https://ask.libreoffice.org/en/questi... It could be this bug: https://bugs.documentfoundation.org/s...

ebot gravatar imageebot ( 2018-09-05 15:29:13 +0200 )edit

Indeed, it is the same problem. I'll just have to revert to libreoffice 5. Thanks.

Goran gravatar imageGoran ( 2018-09-06 09:45:36 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2018-09-04 12:10:03 +0200

Seen: 907 times

Last updated: Sep 05 '18