disable auto full screen for embedded videos

How can I disable the automatic full screen mode of embedded videos in Impress? I would like the video to be played in the slide show where it was inserted, and in the size chosen by the user when inserted.

I recently upgraded libreoffice from to, where in version 5, this was no problem.

Select in the menu Slide Show>Presentation Settings in Presentation Mode. Is that what you are looking for?

I’m afraid not. Presentation mode under slide show settings, let’s one choose between “full screen” and “In a window”. This does not change how videos are displayed.

Which dimensions does your video have in edit mode?
Which OS do you use?

Just like an image, I would like to adjust the size of my video inside the slide. I do not understand what you mean with “dimensions” in this setting. I’m running linux (ubuntu 18.04).

if using linux (eg ubuntu 18.04), you can remove libreoffice-gtk3 and install libreoffice-gtk2. more: https://www.reddit.com/r/libreoffice/comments/b0jrdn/impress_embed_video_always_plays_fullscreen/

update: it might be missing package with gtk3, solving by installing apt install gstreamer1.0-gtk3

@gsedej 's comment above solves the problem for me. Odd that Debian/Ubuntu do not ship the module with this dependency perhaps.

When I insert a video with me, it is displayed very large (33,87 x 19,05 cm):

The display size can be reduced in the sidebar, e.g. 10 x 5,62 cm:

Look for a check mark “Keep aspect ratio”.

image description

Yes, I know. However, my problem is that the inserted video, no matter how it’s position has been modified and the “keep aspect ratio” option is on, the video is automatically displayed in full screen when I’m presenting the slide show. The video is therefore on top of other things that I might have in the slide.

Choosing to “protect” position and size does not work either

Here are some answers to the same problem:

It could be this bug:

Indeed, it is the same problem. I’ll just have to revert to libreoffice 5. Thanks.