Ask Your Question
0

Why does LO use discrete graphics, not integrated?

asked 2018-09-23 09:25:03 +0100

bdun gravatar image

updated 2018-09-24 01:56:31 +0100

Soffice.bin forces the use of my Nvidia graphics card, not the integrated card on my laptop. I can see no reason why it it automatically causing Nvidia to kick in. The laptop battery drains extremely fast when all I'm doing is working in LibreOffice! If this is a bug - please fix it.

edit retag flag offensive close merge delete

Comments

Does this happen with all documents? Or is it only for special documents? In case changing the settings mentioned by ebot does not help, you can look into the settings of your graphic card. I have a combination with internal Intel HD Graphics and separate NVIDIA GeForce. The driver settings allow to force its use by an app or to prevent its use by an app. Perhaps you examine the settings of your operating system?

Regina gravatar imageRegina ( 2018-09-23 14:53:30 +0100 )edit

All documents. I don't use any special or more advanced features as I'm a student, and I type my notes and make simple spreadsheets (like for terms and definitions, and some math calculations.

I've looked into editing the settings in Nvidia to force LibreOffice to use Integrated graphics, but I am unable to choose soffice.bin (which is what my Nvidia shows is running with discrete graphics) because it's not an .exe, but a .bin which is not executable in Windows.

bdun gravatar imagebdun ( 2018-09-24 01:52:20 +0100 )edit

You can use preferred "Integrated Graphics" in the Global Settings or you Add LibreOffice in the Program Settings. Select it as 1. Step and then select "Integrated Graphics" in the drop-down list of 2.Step.

The program is soffice.exe, that is the wrapper for soffice.bin for Windows. It should be in the list, which you get with the Add button. Hovering an item shows the location and 'last used'.

Regina gravatar imageRegina ( 2018-09-24 03:29:26 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-09-23 09:49:30 +0100

ebot gravatar image

Please check what you have set in the menu under Tools>Options>View there in Graphic output. Write down the settings. Make different settings for testing.

The same goes for Tools>Options>OpenCL.

You can make bugs or suggestions for modification at Bugzilla:

https://bugs.documentfoundation.org/

edit flag offensive delete link more

Comments

Turning off the default-enabled checkbox "Use OpenGL for all rendering" solved the problem. Thank you!

bdun gravatar imagebdun ( 2018-09-24 01:55:01 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-23 09:25:03 +0100

Seen: 168 times

Last updated: Sep 23 '18