Ask Your Question
0

Why does LibreOffice Writer keep replacing a short line of characters with thick line?

asked 2018-11-10 10:09:33 +0100

jopower gravatar image

updated 2018-11-10 10:41:31 +0100

Hi Libre Techs: I often separate a sub-topics in a note, email or letter with a short line of -------------- or =========== or ++++++++++++ or _______________. I am becoming infuriated by Writer replacing these with a full margins width thick solid line when I press ENTER at the end of my short repeated character line. Further, it keeps adding thick lines if I press ENTER to get passed it. If I press ENTER at the end of the text ABOVE the line, another thick line is added. In each case, if there is any text just above the thick line BACKSPACE doesn't work to remove it, but does if there is no text immediately above it. If I try to highlight the line to delete it, local words are always picked up also, as if I had underlined the word, which I didn't. The toolbar underline icon isn't enabled either. To get rid of this line I have to copy out my text, make space further up the page, paste the words into WORDPAD where they are safe, highlight the thick lines and delete. Then I can copy out of Wordpad to Writer and lines are gone. In fact if I do the whole doc in Wordpad, there is no problem at all, except that Writer has the options and fonts I very much prefer. As I said, it's infuriating!!! I want this "feature" REMOVED FOREVER!!!

Here's an example. All thick lines were once "===================" that I pressed ENTER behind. (Oddly, when I tried to copy-paste to this query box, the lines completely disappeared. So I've had to make a print screen shot):

image description

Further, I have just found that if I press ENTER anywhere in the paragraph immediately above a thick line, another thick line is made right in the middle of the text. Here's an example (compare to 1st screen shot):

image description

I absolutely despise this behavior! And I should add that if I run a short line of ~~~~~~~~~~~~~~~~~~~, I get a doubled line (one thick and one thin)!!!

Now, for reference, this is how the page is SUPPOSED to look:

image description

So... how do I fix it permanently = make sure this is not enabled ever again?? Also recommend that it not be enabled in ANY future version you send out to others. Thank you for your help!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-11-10 10:43:37 +0100

ebot gravatar image

Hi, instead of getting angry and despising behavior in LibreOffice, you should learn how LibreOffice works. Go to the menu Tools>Auto Correction>As you type and click on it so that it is off (no checkmark anymore). Also in the menu Tools>Auto Correction>AutoCorrect Options you can determine what should work. Take a close look at this topic and test what is most suitable for you. The documentation of LibreOffice can be found here.

edit flag offensive delete link more
0

answered 2018-11-10 10:32:49 +0100

Mike Kaganski gravatar image

I am becoming infuriated by Writer replacing ...

Please never become infuriated by anything that is just you not knowing how to operate some feature of things you use. Asking is fine; becoming angry is not healthy ;-)

ToolsAutoCorrectAutoCorrect Options...Options;

  • replacement of --- and === to single or double paragraph borders are controlled by Apply border;
  • replacement of ++ to tables is controlled by Create table.

Uncheck and enjoy.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-10 10:09:33 +0100

Seen: 29 times

Last updated: Nov 10