Why does LibreOffice Writer keep replacing a short line of characters with thick line?

Hi Libre Techs:
I often separate a sub-topics in a note, email or letter with a short line of -------------- or =========== or ++++++++++++ or _______________. I am becoming infuriated by Writer replacing these with a full margins width thick solid line when I press ENTER at the end of my short repeated character line. Further, it keeps adding thick lines if I press ENTER to get passed it. If I press ENTER at the end of the text ABOVE the line, another thick line is added. In each case, if there is any text just above the thick line BACKSPACE doesn’t work to remove it, but does if there is no text immediately above it. If I try to highlight the line to delete it, local words are always picked up also, as if I had underlined the word, which I didn’t. The toolbar underline icon isn’t enabled either. To get rid of this line I have to copy out my text, make space further up the page, paste the words into WORDPAD where they are safe, highlight the thick lines and delete. Then I can copy out of Wordpad to Writer and lines are gone. In fact if I do the whole doc in Wordpad, there is no problem at all, except that Writer has the options and fonts I very much prefer. As I said, it’s infuriating!!! I want this “feature” REMOVED FOREVER!!!

Here’s an example. All thick lines were once “===================” that I pressed ENTER behind. (Oddly, when I tried to copy-paste to this query box, the lines completely disappeared. So I’ve had to make a print screen shot):

Further, I have just found that if I press ENTER anywhere in the paragraph immediately above a thick line, another thick line is made right in the middle of the text. Here’s an example (compare to 1st screen shot):

I absolutely despise this behavior! And I should add that if I run a short line of ~~~~~~~~~~~~~~~~~~~, I get a doubled line (one thick and one thin)!!!

Now, for reference, this is how the page is SUPPOSED to look:

So… how do I fix it permanently = make sure this is not enabled ever again?? Also recommend that it not be enabled in ANY future version you send out to others. Thank you for your help!

1 Like

I am becoming infuriated by Writer replacing …

Please never become infuriated by anything that is just you not knowing how to operate some feature of things you use. Asking is fine; becoming angry is not healthy :wink:

Tools→AutoCorrect→AutoCorrect Options...→Options;

  • replacement of — and === to single or double paragraph borders are controlled by Apply border;
  • replacement of ++ to tables is controlled by Create table.

Uncheck and enjoy.

1 Like

I think he is quite entitled to become infuriated! I type 10 underscores and get a line the full width of the screen. If I type abc it does not get replicated across the screen! If you want that sort of behaviour it should be something that needs to be switched ON, it should NOT be the default. Your answer does not explain how to stop it, just gives an options area to look in.

This is not the manual, but helps a lot.

Hi, instead of getting angry and despising behavior in LibreOffice, you should learn how LibreOffice works. Go to the menu Tools>Auto Correction>As you type and click on it so that it is off (no checkmark anymore). Also in the menu Tools>Auto Correction>AutoCorrect Options you can determine what should work. Take a close look at this topic and test what is most suitable for you. The documentation of LibreOffice can be found here.

Really! “…” (redacted by LeroyG)
So we can’t expect Libre Office to work in an intuitive way, we have to dig around the documentation to switch off stupid behaviour. Software is like telling a joke, if you have to explain it then it’s not good.

Software is like telling a joke, if you have to explain it then it’s not good.

Really! Have you seen how many books and magazines there are for software?

One can say a good software needs also a good documentation. And you can work on that. Help us to improve the documentation.

Get Involved

What can you do for LibreOffice?