Ask Your Question
0

Text format in alphabetical index

asked 2018-11-18 21:25:09 +0200

Joe-- gravatar image

LO Writer 6.1.2

I've created an alphabetical index for my document. The problem I am having is that if I create in index entry for text that is formatted with italics, the index entry is also formatted with italics.

I have seen some messages from people asking for this functionality in prior versions, and while i can see why it might be desired, I do not want this in my case.

How do I prevent index entries from using the text format from the indexed text?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-11-19 08:13:18 +0200

ajlittoz gravatar image

Can't reproduce but I'm using an older version.

I suppose you're entering the entries by selecting the word then Insert>Indexes & Tables>Entry. This may capture all formatting (character style or direct formatting) though I don't see it.

There is an alternate way of entering index entry to the cost of more manual work. Put the cursor inside the to-be-indexed word (immediately at the beginning also works), without selecting any run of characters (this is a "spot" position, not a range). Insert the index entry. Since no run of characters is selected, you must enter the index term yourself. In this way, it does not inherit any formatting property from main text.

edit flag offensive delete link more

Comments

Thanks, that works.

I had actually tried that before, but I had done it after creating the entry the "normal" way. Seems that creating an entry, deleting it, and then creating a manual entry with zero characters selected will retain the original entry's format. But if I create it initially with zero characters selected, it works.

Joe-- gravatar imageJoe-- ( 2018-11-20 01:34:12 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-18 21:25:09 +0200

Seen: 29 times

Last updated: Nov 19 '18