We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

win7: libre 3.5.1 very slow [closed]

asked 2012-04-05 21:30:36 +0200

vergna gravatar image

updated 2015-10-16 00:11:33 +0200

Alex Kemp gravatar image

I've a Win 7 64bit (4GB - Intel I7 K875) and Libreoffice 3.5.1 is very very slow. When I start to write the words there is a freeze a few seconds before you see them on the sheet.(on writer)

Also the pressure on the icons reacts with a certain delay.

The version of Java installed is the 6.31

Any Idea ?


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 00:11:43.762450

3 Answers

Sort by » oldest newest most voted

answered 2012-05-03 21:10:28 +0200

vergna gravatar image

Version 3.5.3 seems to have solved the problem

edit flag offensive delete link more


manj_k gravatar imagemanj_k ( 2013-01-26 21:46:33 +0200 )edit

answered 2012-04-06 18:04:10 +0200

SeanOScare gravatar image

updated 2012-04-06 18:05:45 +0200

I have found a solution to your problem, one that I myself acquired from another Libreoffice user. Simply run the installer for the latest version of 3.5 you have, click modify and custom installation. Uncheck all the dictionary extensions except for the language you wish to use. You might need some of the other languages but I highly doubt it. When you click install these will be removed, open Libreoffice up and it should be running smoothly once again.

Additionally, do take the advice on tweaking your memory settings. Under Options>Memory>graphics cache, increase your allocated memory for use in Libreoffice to max; 256mb. Reduce the number of undo steps to 30 and check load Libreoffice quickstarter. Under Options>Java uncheck use Java runtime environment. I hope all this helps.

edit flag offensive delete link more


After these tests, typing is faster remains slow response icons.

For example, when I click on the icon of the bold

vergna gravatar imagevergna ( 2012-04-06 18:52:25 +0200 )edit

This is after uninstalling all the other dictionary language extensions? After I did that LibreOffice started working fine. If you're working in English uninstall all other language dictionaries.

SeanOScare gravatar imageSeanOScare ( 2012-04-06 21:56:31 +0200 )edit

Yes, I'm working with Italian dictionary

vergna gravatar imagevergna ( 2012-04-07 10:21:31 +0200 )edit

answered 2012-04-06 03:30:00 +0200

jmjf gravatar image

Second this. I went back to 3.4 because Writer 3.5.1's performance made it unusable.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-04-05 21:30:36 +0200

Seen: 3,483 times

Last updated: May 03 '12