Ask Your Question
0

Recording macro dialogue box missing

asked 2018-12-03 16:00:36 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In following on-line Libre directions to use macros, I installed latest Java JRE and got into the tools>macro menu item.

I hit 'record macro', but see no 'recording macro dialogue box' as mentioned in directions. Suggestions?

I am running Version: 6.1.3.2 (x64) Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb

What I want to do is to set up a macro that will be a copy a few paragraphs of a Libre Writer doc, save macro to the keyboard, then press a couple keys to insert that text in the macro into Facebook chat window with friends.

Thank you!

Mike (A new user of community help, but not of Libre Office.)

edit retag flag offensive close merge delete

Comments

  1. To use/record macros, Java is not needed.
  2. You haven't mentioned your OS.
  3. Wrt (irrelevant) Java path problem: have you installed 64-bit Java? because 64-bit Java is required with 64-bit LO.

The problem with absent recording window is, indeed, strange. Did you try to reset your user profile?

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-04 09:57:56 +0100 )edit

Solved. I reinstalled 64bit, and made sure all other programs were closed. Works now. Thanks!

Mike Eugene gravatar imageMike Eugene ( 2018-12-05 02:28:42 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-03 18:38:32 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have Java 8 build 191 installed, and run Wind 10 Pro.

Thank you but box is checked to enable macro recording. However I don't see how to fill in the "select Java path" section above that. I can't find a Java JRE file in the sub directories. It is like something is missing there.

C:\fakepath\JAVA path shot for help.odt

edit flag offensive delete link more

Comments

Java 8 build 191 - but is it 64-bit? can you post the full name of the installer package you downloaded to install it? Did you follow the See all Java downloads link at Java site, or did you just use the Big Red Button there, that helpfully offers you the 32-bit package unconditionally?

But again - the Java is not required for macro recorder to work, so - did you try to reset LO user profile?

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-04 19:44:07 +0100 )edit
0

answered 2018-12-03 18:11:39 +0100

Pansmanser gravatar image

You probably need to enable macro recording. Tools-Options-Libreoffice-Advanced and tick one or both boxes at the bottom of the window.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-03 16:00:36 +0100

Seen: 30 times

Last updated: Dec 04