Ask Your Question
0

Base crashes

asked 2018-12-05 13:31:10 +0200

Wanabee gravatar image

updated 2018-12-05 13:41:21 +0200

Hi! I am using LibreOffice 6.0.6.2 on Ubuntu 18.04.1 LTS.

When I try to create a new Database using Base or if I try to open an existing database Base crashes.

I am able to open my existing Database, but when I try to open the included form Base crashes. Even worse, when I try to create a new Database. I am able to enter a new Filename, but then Base crashes.

Any thoughts?

Thank you very much!

Arne

edit retag flag offensive close merge delete

Comments

Have you installed a Java JRE and verified its installation in LO?

Ratslinger gravatar imageRatslinger ( 2018-12-06 19:11:29 +0200 )edit

Hi Ratslinger!

I am not sure, what you mean. How do I verify the installation in LO?

I think, I do have "Java JRE" installed:

# apt search "JRE" | grep -i "install"
default-jre/bionic,now 2:1.10-63ubuntu1~02 i386  [Installiert,automatisch]
default-jre-headless/bionic,now 2:1.10-63ubuntu1~02 i386  [Installiert,automatisch]
docbook-xsl/bionic,now 1.79.1+dfsg-2 all  [Installiert,automatisch]
libopenjfx-java/bionic,now 8u161-b12-1ubuntu2 all  [Installiert,automatisch]
libtwelvemonkeys-java/bionic,now 3.3.2-2 all  [Installiert,automatisch]
openjdk-11-jre/bionic-updates,bionic-security,now 10.0.2+13-1ubuntu0.18.04.4 i386  [Installiert,automatisch]
openjdk-11-jre-headless/bionic-updates,bionic-security,now 10.0.2+13-1ubuntu0.18.04.4 i386  [Installiert,automatisch]
openjdk-8-jre/bionic-updates,bionic-security,now 8u191-b12-0ubuntu0.18.04.1 i386  [Installiert,automatisch]
openjdk-8-jre-headless/bionic-updates,bionic-security,now 8u191-b12-0ubuntu0.18.04.1 i386  [Installiert,automatisch]
Wanabee gravatar imageWanabee ( 2018-12-07 13:35:02 +0200 )edit

Sorry, went out of comment space.

Am I missing something?

Thanks for your help!

Arne

Wanabee gravatar imageWanabee ( 2018-12-07 13:37:01 +0200 )edit

From menu Tools->Options then under LibreOffice->Advanced, 'Use a Java runtime environment' needs to be checked & then a JRE selected in the window just below that. It also appears your list shows 32-bit Java installs. Is your LO version 32-bit?

Ratslinger gravatar imageRatslinger ( 2018-12-07 17:58:41 +0200 )edit

Hi Ratslinger! Even though there are two JRE available (Oracle Corporation 10.0.2 and Oracle Corporation 1.8.0_191) none was selected. I tried both versions with no different result: Base crashes when I try to open the included Form.

I believe I am using a 32-Bit Linux. Here is what uname -a has to say:

Linux Tracy-Beaker 4.15.0-42-generic #45-Ubuntu SMP Thu Nov 15 19:32:10 UTC 2018 i686 i686 i686 GNU/Linux

So, LO is probably 32Bit. I hope that helps. The basic Installation is a few years old. I believe, I installed Ubuntu 14LTS. Then I upgraded to 16LTS and on to 18LTS. Until the last Upgrade to 18LTS everything was fine.

Thanks again for your help! Do you have any other hints?

Best regards

Arne

Wanabee gravatar imageWanabee ( 2018-12-11 06:05:54 +0200 )edit

@Wanabee Based on your further information and from past answers & testing, the answer already given by @kompilainenn is the answer. Have personally tested this in the past and verified its success.

See also answer by @rbscebu in this post -> How do I get Base to work under Lubuntu 16.04?.

For further instructions on setting this parameter, see this post -> How do I add a kernel boot parameter?.

Ratslinger gravatar imageRatslinger ( 2018-12-11 17:05:50 +0200 )edit

Hi @Ratslinger!

You are right! @kompilainenn had the right answer all the time, alone I was to stupid to do it the right. When I tried the solution the first time, I just tried to temporarily add a boot parameter. And I did it wrong. This time a tried the permanent solution, got it right and it works like a charme!

I am sorry or wasting your time, but thank you for sticking with me.

Best regards! Arne

Wanabee gravatar imageWanabee ( 2018-12-12 13:44:16 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-05 15:12:03 +0200

kompilainenn gravatar image

updated 2018-12-13 14:53:11 +0200

It may be problem with Java and security politic in Linux kernel.

https://bugs.documentfoundation.org/s...

You can solution it uses kernel parameter stack_guard_gap=6 in GRUB

edit flag offensive delete link more

Comments

Hi kompilainenn!

I tried

stack_guard_gap=1

and

stack_guard_gap=6

Both did not help. Sorry! Do you have any other Ideas? But thanks for your help!

Arne

Wanabee gravatar imageWanabee ( 2018-12-05 18:28:42 +0200 )edit

Do you have any other Ideas?

Sorry, no idea

kompilainenn gravatar imagekompilainenn ( 2018-12-06 09:04:50 +0200 )edit
0

answered 2018-12-12 13:50:04 +0200

Wanabee gravatar image

@kompilainenn has the right answer!

Adding stack_guard_gap=1 as a boot-parameter does the trick. Only make sure to really add the boot-parameter to the right line as described in this post: https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Best regards

Arne

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-05 13:31:10 +0200

Seen: 111 times

Last updated: Dec 13 '18