Ask Your Question

Will LibreOffice open .wks spreadsheets? [closed]

asked 2018-12-07 20:30:23 +0200

nic gravatar image

updated 2020-07-30 00:01:01 +0200

Alex Kemp gravatar image

My LibreOffice will open MS WORKS .wps files but not .wks - how can I do this?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-07-30 00:02:20.683084


What version of MS Works?

Lupp gravatar imageLupp ( 2018-12-07 21:44:47 +0200 )edit

Please provide a sample .wks

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-08 10:49:57 +0200 )edit

Lupp: I don't know, sorry [file on a disc given to me to try to access] but a good question since I can open some of the other .wks files [doubleclick opens a dialogue 'Import Lotus files' with a default to 'Western Europe (DOS2-437/US). Doubleclick on the problem file opens a 'Text Import' dialogue showing a worksheet with mainly [Chinese?] characters which could never have been the intended content. MK: How do I add a file to this comment box please? [I tried 'help' but not helpful]

nic gravatar imagenic ( 2018-12-08 19:28:34 +0200 )edit

@nic: please create a bug report at There please describe that LO doesn't open some WKS files; mention your LO version and OS; and attach a sample file (there's a form for that). Please mention the bug # here afterwards. Thanks.

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-08 20:27:15 +0200 )edit

@Mike Kaganski : thanks for the advice - I thought this was a simple question but it looks like I may need to give more detail. It may be relevant that I am on LO Version: Build ID: 420m0(Build:2), and maybe later versions don't have this issue?. I am using this version because it's the latest authenticated for the Ubuntu 14.04LTS that I run. I am very reluctant to move to a later version of LO until Ubuntu authenticates a new version by including it in Synaptic due to the personal disaster caused by the bug in LibreOffice version 4.2.6&7 [] which scrambled many of my cell references and wasted days. I will log a bug when the site will let me in.

nic gravatar imagenic ( 2018-12-09 14:11:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-12-08 08:57:27 +0200

ebot gravatar image

In any case, the file type is offered in the Open menu.

image description

edit flag offensive delete link more


Thanks ebot, but if I right click on the file> select 'Open With'> select 'Other Application'> select 'Show Other Applications' I get a list with icons that doesn't look like the one you show above. Please give a step by step route to get to the dialogue above. Thanks nic

nic gravatar imagenic ( 2018-12-08 19:12:40 +0200 )edit

From the File>Open menu, click All Files (*. *). And please follow the request of @Mike Kaganski.

ebot gravatar imageebot ( 2018-12-09 13:36:00 +0200 )edit

@ebot thanks again. I will log a bug when finally decides to send me a new password to replace the one it took down for some reason. To help anyone else following this thread the steps you need to take are: 1/ Open a new [or any] Calc spreadsheet BUT NOT the one you're trying to actually open 2/ In the top bar Click File>Open 3/ Navigate to the file you want to open 4/ at the bottom of the dialogue in 'File Type' search for 'All Files (.)'. However, unfortunately on this PC, 'All Files (.)' is not offered as an option [only 'All Files']. However, I did manage to find 'Lotus 1-2-3 *.wks' but that just reports 'Read Error Unknown Lotus 1-2-3 format'

nic gravatar imagenic ( 2018-12-10 11:32:56 +0200 )edit

Writing a bug report certainly makes sense in this case. If you have written the bug, please post the link here. Different representations in LibreOffice may also be caused by different operating systems.

ebot gravatar imageebot ( 2018-12-10 12:53:27 +0200 )edit

will add a sample of the failing .wks here if someone will tell me how please.

nic gravatar imagenic ( 2018-12-11 09:55:23 +0200 )edit

Edit your question. Click on the "Attachment" icon. Add your file attachment.

ebot gravatar imageebot ( 2018-12-11 10:13:24 +0200 )edit

@ebot - thanks again [sorry for delay > broadband collapse]. I tried to EDIT but I was not allowed to add the sample file. A dialogue appeared saying " says: allowed file types are '.jpg', '.jpeg', '.gif', '.bmp', '.png', '.tiff', '.odt', '.ods', '.odp', '.odg', '.odc', '.odf', '.odi', '.odm', '.ott', '.ots', '.otp', '.otg', '.odb', '.doc', '.docx', '.xls', '.xlsx', '.ppt', '.pptx'" I will try again although it always seems to chuck out my password.

nic gravatar imagenic ( 2018-12-19 19:21:31 +0200 )edit

Question Tools

1 follower


Asked: 2018-12-07 20:30:23 +0200

Seen: 309 times

Last updated: Dec 08 '18