Will LibreOffice open .wks spreadsheets?

My LibreOffice will open MS WORKS .wps files but not .wks - how can I do this?

What version of MS Works?

Please provide a sample .wks

Lupp: I don’t know, sorry [file on a disc given to me to try to access] but a good question since I can open some of the other .wks files [doubleclick opens a dialogue ‘Import Lotus files’ with a default to 'Western Europe (DOS2-437/US). Doubleclick on the problem file opens a ‘Text Import’ dialogue showing a worksheet with mainly [Chinese?] characters which could never have been the intended content.
MK: How do I add a file to this comment box please? [I tried ‘help’ but not helpful]

@nic: please create a bug report at bugs.documentfoundation.org. There please describe that LO doesn’t open some WKS files; mention your LO version and OS; and attach a sample file (there’s a form for that). Please mention the bug # here afterwards. Thanks.

@mikekaganski : thanks for the advice - I thought this was a simple question but it looks like I may need to give more detail. It may be relevant that I am on LO Version: Build ID: 420m0(Build:2), and maybe later versions don’t have this issue?. I am using this version because it’s the latest authenticated for the Ubuntu 14.04LTS that I run. I am very reluctant to move to a later version of LO until Ubuntu authenticates a new version by including it in Synaptic due to the personal disaster caused by the bug in LibreOffice version 4.2.6&7 [www.libreoffice.org/bugzilla/show_bug.cgi?id=86754] which scrambled many of my cell references and wasted days. I will log a bug when the site will let me in.

In any case, the file type is offered in the Open menu.

Thanks ebot, but if I right click on the file> select ‘Open With’> select ‘Other Application’> select ‘Show Other Applications’ I get a list with icons that doesn’t look like the one you show above. Please give a step by step route to get to the dialogue above.

From the File>Open menu, click All Files (*. *). And please follow the request of @mikekaganski.

@Hrbrgr thanks again. I will log a bug when https://bugs.documentfoundation.org finally decides to send me a new password to replace the one it took down for some reason.
To help anyone else following this thread the steps you need to take are: 1/ Open a new [or any] Calc spreadsheet BUT NOT the one you’re trying to actually open 2/ In the top bar Click File>Open 3/ Navigate to the file you want to open 4/ at the bottom of the dialogue in ‘File Type’ search for ‘All Files (.)’.
However, unfortunately on this PC, ‘All Files (.)’ is not offered as an option [only ‘All Files’]. However, I did manage to find ‘Lotus 1-2-3 *.wks’ but that just reports ‘Read Error Unknown Lotus 1-2-3 format’

Writing a bug report certainly makes sense in this case. If you have written the bug, please post the link here. Different representations in LibreOffice may also be caused by different operating systems.

will add a sample of the failing .wks here if someone will tell me how please.

Edit your question. Click on the “Attachment” icon. Add your file attachment.

@Hrbrgr - thanks again [sorry for delay > broadband collapse]. I tried to EDIT but I was not allowed to add the sample file.
A dialogue appeared saying "asklibreoffice.org says: allowed file types are ‘.jpg’, ‘.jpeg’, ‘.gif’, ‘.bmp’, ‘.png’, ‘.tiff’, ‘.odt’, ‘.ods’, ‘.odp’, ‘.odg’, ‘.odc’, ‘.odf’, ‘.odi’, ‘.odm’, ‘.ott’, ‘.ots’, ‘.otp’, ‘.otg’, ‘.odb’, ‘.doc’, ‘.docx’, ‘.xls’, ‘.xlsx’, ‘.ppt’, ‘.pptx’"
I will try bugs.documentfoundation.org again although it always seems to chuck out my password.