Ask Your Question
0

Why does calc INSIST on capitalizing "I" no matter what autocorrect setting I use?

asked 2018-12-08 21:58:31 +0100

STMRadio gravatar image

updated 2018-12-08 22:10:15 +0100

I am entering foreign words, one of which is "i" (NOT capitalized) but calc is capitalizing it almost at random it seems (I'm sure there is some logic to it, but I don't see it). If I laboriously go back and correct each and every one, sometimes it takes, and sometimes it instantly autocorrects it back to "I". I have tried Tools>AutoCorrect options>uncheck Capitalize the first letter of every sentence, but that has NO EFFECT AT ALL. And some of these "i's" are after a comma and space, not at the beginning of a line. I have tried clearing all the checkmarks in Tools>Options>Language settings>Writing Aids (NOPE) and opening Writer and clearing the check at Tools>AutoCorrect>While typing (NOPE) and restarting the document (NOPE). I haven't tried rebooting the operating system... This is clearly a bug that needs addressing.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-12-08 22:10:22 +0100

Mike Kaganski gravatar image

Check the first tab of the Autocorrect Options (Replace tab) for your used language (the selector on top of the dialog). Look for the replacement pair iI and remove if needed.

edit flag offensive delete link more
0

answered 2018-12-08 22:15:54 +0100

STMRadio gravatar image

updated 2018-12-08 22:19:09 +0100

I solved this problem by doing Tools>AutoCorrect Options>Options and unchecking EVERY box there. It finally let go and let me control my spelling. Someone, please find out why that was necessary.

OK, while I was typing this someone answered with a less drastic solution. I hadn't looked there because the list is so long and I didn't know that i > I entry was there. I edited it to i > i. Thank you.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-08 21:58:31 +0100

Seen: 26 times

Last updated: Dec 08