Why does calc INSIST on capitalizing "I" no matter what autocorrect setting I use?

I am entering foreign words, one of which is “i” (NOT capitalized) but calc is capitalizing it almost at random it seems (I’m sure there is some logic to it, but I don’t see it). If I laboriously go back and correct each and every one, sometimes it takes, and sometimes it instantly autocorrects it back to “I”. I have tried Tools>AutoCorrect options>uncheck Capitalize the first letter of every sentence, but that has NO EFFECT AT ALL. And some of these “i’s” are after a comma and space, not at the beginning of a line.
I have tried clearing all the checkmarks in Tools>Options>Language settings>Writing Aids (NOPE) and opening Writer and clearing the check at Tools>AutoCorrect>While typing (NOPE) and restarting the document (NOPE). I haven’t tried rebooting the operating system…
This is clearly a bug that needs addressing.

Check the first tab of the Autocorrect Options (Replace tab) for your used language (the selector on top of the dialog). Look for the replacement pair iI and remove if needed.

I solved this problem by doing Tools>AutoCorrect Options>Options and unchecking EVERY box there. It finally let go and let me control my spelling. Someone, please find out why that was necessary.

OK, while I was typing this someone answered with a less drastic solution. I hadn’t looked there because the list is so long and I didn’t know that i > I entry was there. I edited it to i > i.
Thank you.