Ask Your Question
1

Calc 4.0.3.3 very slow when editing formulas [closed]

asked 2013-05-21 21:16:23 +0100

Teodor Constantinescu gravatar image

updated 2016-02-18 17:42:35 +0100

Alex Kemp gravatar image

I'm using Libre Office on a Dell laptop. Resources are fine, Intel i5 and 8 gigs of memory. I started experiencing this after upgrading from 4.0.2.x to 4.0.3.3.

What happens is that I have to wait for ~ 3 seconds after double clicking a cell or pressing F2 until edit mode is activated. The same happens when I exit edit mode. Worth mentioning that this is happening only after I do some work in the file, maybe 10 minutes or so. If I close and reopen the slow edit disappears to reappear in a few minutes.

I didn't yet notice whether the time lap between triggering edit mode and actually entering edit mode increases with time.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 17:42:51.401897

3 Answers

Sort by » oldest newest most voted
1

answered 2014-01-21 16:25:16 +0100

jeffreyswigart gravatar image

I had this same problem, and through some Google searching fell upon the solution of disabling Java completely.

Tools --> Options --> Libre Office --> Advanced --> Use a Java Runtime Environment (DESELECT)

Now my formula editor loads up lightning fast, and in fact, the entire Libre Office loads up significantly faster as a whole.

I'm not that knowledgeable about the inner workings of Libre Office, but I read in my other Google searching that the only potential drawback of this solution is that some functions of the software depend on Java. I have not run into any problems yet, so they must not be often-used functions.

I hope this helps.

edit flag offensive delete link more
1

answered 2013-05-22 00:30:31 +0100

mahfiaz gravatar image

See menu Tools → Options, under memory set the whole memory limit to > 100 MB and objects in memory limit (the important one) to some larger number, I have 1000 there. You could raise other limits as well.

edit flag offensive delete link more

Comments

Ok, did this, now looking for changes in behaviour.

Teodor Constantinescu gravatar imageTeodor Constantinescu ( 2013-06-01 22:34:15 +0100 )edit
0

answered 2013-05-22 00:36:47 +0100

m.a.riosv gravatar image

Or try resetting the user profile, sometimes resolves strange issues.

https://wiki.documentfoundation.org/UserProfile

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-05-21 21:16:23 +0100

Seen: 995 times

Last updated: Jan 21 '14