Ask Your Question
0

Numbering List Format change for each successive sub-numbered list

asked 2019-01-16 04:47:46 +0200

Jabran gravatar image

updated 2019-01-17 04:41:48 +0200

Hi All,

I want to change the numbering format for each successive sub-numbered list but cant seem to do that in libreoffice. (Microsoft office seems to sort it out though) . I would like to know if i can do it in libre office.

Below is what i want to achieve: C:\fakepath\LibreOffice_Numbering.png

You see in the picture the list above is what i am able to achieve. The format below is what i want to do.

You see when i change the format of second sub-numbered list, the first one changes along with it. This is, I think, because they are on the same sub-level. Is there a way to disconnect the two sub-level lists.

I hope the community answers my question.

Thanks and regards, Jabran

Edit:

I created the list through the numbering button. The start of list by indenting is by accident. I just want the first bullet lets say numbered 1 to have sub-bullets as 1.1, 1.2, 1.3 etc. And each 1.1 to have sub- bullets as 1.1.1, 1.1.2 and so on for 1.2 and 1.3 also.

I appreciate your effort. Please help me find a solution to this.

Edit 2:

Here is a sample file that i created that explains further. File link is https://drive.google.com/open?id=15RW...

Regards,

edit retag flag offensive close merge delete

Comments

Lists are best controlled through "style" usage. Quick'n'dirty list entry can be done with buttons in the toolbar but that results in a generic "thought-to-be universal" format. You didn't tell how you created your list.

The level of a list item is defined by the number of Tab characters before the item. As a consequence, DO NOT USE tab characters to align your items. Alignment must be done through style or Format>Bullets & Numbering (more details at time of real answer).

The strange thing is you start your list at level 2 instead of 1. Is this intended?

Please provide this supplemental information editing your question (theeditlink with a pencil) not with an answer.

ajlittoz gravatar imageajlittoz ( 2019-01-16 09:07:21 +0200 )edit

@ajlittoz i provided the information. Plz help

Jabran gravatar imageJabran ( 2019-01-16 14:55:36 +0200 )edit

Attach your sample document: either upload it to some file server and put the link in your question; or, if you can't, i'll upvote your question to give you enough karma to be able to attach a file to the question.

ajlittoz gravatar imageajlittoz ( 2019-01-16 18:23:52 +0200 )edit

@ajlittoz I have uploaded the file and shared the link. thanks.

Jabran gravatar imageJabran ( 2019-01-17 04:42:46 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2019-01-17 10:18:44 +0200

RGB-es gravatar image

As a complement of @ajlittoz excellent answer, you can check this article (it has some screenshots ;) ): Numbered and bulleted lists alignment on LibreOffice Writer

edit flag offensive delete link more
0

answered 2019-01-17 08:25:37 +0200

ajlittoz gravatar image

Your problem boils down to setting the alignment in your list items. Since you create your list with the toolbar button(s), the settings are accessed with Format>Bullets & Numbering.

Consider only Position and Customize tabs. The others are only shortcuts to preset parameters in the aforementioned tabs. Very important: once you start playing with the parameters, never go back to the "shortcut" tabs otherwise you'll end up with an unmanageable mess.

Tab Position controls where the list item and its bullet/number is located. Aligned at tells where the bullet/number will start. Indent at sets the item left margin (this is the paragraph left margin if it was not a list item). It is recommended that the Tab stop at is equal to Indent at so that the first line for the list item start at the same position as subsequent line but you may have different needs.

Tab Customize controls the appearance of the bullet/numbering. The Separator boxes define which characters (or none) are inserted before and after the number.

In your case, you have a dot after at level 1 and none in other levels. This is not consistent. You may correct this here.

In levels 2 and 3, you defined "before" as 1., resp 1.1., which will insert this fixed text in all items. If you want to prefix the item with upper level number, erase the "before" box and increment Show sublevels to the appropriate value (1 for level 1, 2 for level 2, etc.).

Last remark: your document may contain several independent lists. To restart numbering, put the cursor in the first item of the new list, right-click and Restart Numbering. This toggles a flag. To clear it, do the the same.

What is described above is in fact "direct formatting" which frequently causes problems when editing. The recommended method is to create a specific paragraph style, or to adapt a built-in one like *Numbering *, but this is quite complex for beginners. You are encouraged to read the user's guide or the built-in help and discover the style possibilities. Later convert your direct formatting to styles.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
0

answered 2019-01-17 07:47:25 +0200

Grantler gravatar image

@Jabran: You can realize your target with 2 additional customized Numbering Styles. See attachment. - Cheers .

C:\fakepath\SampleNumberingListCustomizedStyles.odt

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-16 04:47:46 +0200

Seen: 40 times

Last updated: Jan 17