Adding dictionary to English LibreOffice to spellcheck a Swedish document

asked 2019-02-01 13:15:33 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am typing a Swedish document and want to spellcheck it in Swedish. I downloaded the Swedish dictionary but it didn't appear in Tools:Spelling:Text language.

So I reinstalled LibreOffice and chose Custom Install and made sure Swedish is included. Now Swedish is included as an option. However English seems to be the default. Each additional Swedish word the spellcheck comes across it reverts to English in the test language dropdown box. I open the box and scroll down to the bottom (past all the English and French and Spanish versions and Swedish (Finland) and select the very last one: Swedish (Sweden). The dropdown box then shows English (UK). I try again. Same result. It vetoes my selection of Swedish (Sweden). I can select Spanish (Honduran) or any of the others but not Swedish (either Finland or Sweden). [Strangely, before I updated LibreOffice I could select Swedish (Sweden) - sometimes. I could then correct the word using the Swedish dictionary. However, when I moved on to the next word in the document the dropdown box again selected English and I had to go through the whole process again (generally having my choice of Swedish rejected by the system again).

(I could just type in the 40-page document in Swedish and check it by eye. The trouble is Swedish has 3 extra characters, ä, å and ö which feature a lot and I have an English keyboard which does not include them. My solution therefore was to type using a and o and use spellcheck (useful anyway, of course), to change them. Otherwise I would have to identify each one and paste ä over the a wherever necessary etc.)

N.B. I have also asked another question concerning an unwanted side effect of all this separately so as not to confuse this issue which is just about checking a document in another language.

Phew, and thank you to anyone who can help.

edit retag flag offensive close merge delete

Comments

From your description, I gather that you use an English keyboard layout to type Swedish. Use a Swedish layout.

For future: 1. Read this tutorial. 2. If you can’t find an answer, read these guidelines and ask a good question.

gabix gravatar imagegabix ( 2019-02-01 13:28:33 +0200 )edit

ToolsLanguageFor All TextMore works here with 6.2.0.3. What is your version?

Mike Kaganski gravatar imageMike Kaganski ( 2019-02-01 13:30:02 +0200 )edit

From your description, I gather that you use an English keyboard layout to type Swedish. Use a Swedish layout.

... or use Ignore system input language setting from OptionsLanguage SettingsLanguages

Mike Kaganski gravatar imageMike Kaganski ( 2019-02-01 13:31:26 +0200 )edit

A good idea for a monolingual document, but will backfire if you need to switch languages.

gabix gravatar imagegabix ( 2019-02-01 14:46:41 +0200 )edit