save gets progressively slower on large document (Writer)

asked 2019-02-08 21:03:32 +0200

groovimus gravatar image

updated 2019-02-08 21:19:55 +0200

I am using ver 6.1 with Win 10 and I've had this problem a long time with this and previous versions and have been searching for a solution. It has not changed over multiple OS updates. I have a 111 page document, (22 figures, ~200 equations, 2.3 MB) that will save normally upon first opening Writer. After that the application will go into the Not Responding (freeze) state right after the green bar finishes. This will start being 5 seconds long and the duration will progress to 5 minutes, 10 minutes, who knows what the limit is. I have to shut down the app and restart and for the first few saves I can tolerate the waiting. I can have a one page document open simultaneaously and the issue does not occur with the shorter document. While in the freeze state, the shorter document is unsurprisingly not accessible. I have not seen this behavior described on here, my apologies if it has been resolved without my seeing it.

Version: 6.1.4.2 Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3 CPU threads: 4; OS: Windows 10.0; UI render: default; Locale: en-US (en_US); Calc: group threaded

edit retag flag offensive close merge delete

Comments

I don't know the cause of your problem but it might help if you allocate more memory to LibreOffice. Menu Tools -> Options -> LibreOffice -> Memory, Under Image Cache, try increasing the first two numbers in the list. Increasing each of those two numbers by about 50% worked for me in a similar situation.

Also try increasing the amount of memory "per object", near the bottom of that dialog box, depending on the present (default) value. I hope this helps.

ve3oat gravatar imageve3oat ( 2019-02-08 21:36:44 +0200 )edit

-OK under tools -> options -> LibreOffice these are the choices: User Data, General, View, Print, Paths, Fonts, Security, Personalization, Application Colors, Accessibility, Advanced, Online Update, Open CL

groovimus gravatar imagegroovimus ( 2019-02-09 03:31:59 +0200 )edit

Sorry. You are using v6 while I was using v5.4. It appears that the memory options have been removed in v6 (at least in v6.1.5.2 which I now have). Please ignore my suggestion (it worked great in v5!). I suspect that memory allocation is now automatically variable so this is not the cause of your problem. I hope you can find a solution.

ve3oat gravatar imageve3oat ( 2019-02-09 16:16:49 +0200 )edit

Thx. will keep fingers crossed for more suggestion

groovimus gravatar imagegroovimus ( 2019-02-09 19:06:47 +0200 )edit